Nacházíte se: WALL.czExcel návod › Proč a jak použít dvě znaménka mínus ve vzorci?
Kategorie: Excel návod

Proč a jak použít dvě znaménka mínus ve vzorci?

ExcelPoužití dvou znamének mínus vedle sebe ve vzorci způsobí, že vzorec převede návratovou hodnotu "PRAVDA" na 1 a návratovou hodnotu "NEPRAVDA" na hodnotu 0.

Tato metoda se většinou používá ve vzorcích SOUČIN.SKALÁRNÍ k převedení podmíněných polí, která vrátí hodnotu PRAVDA/NEPRAVDA na 1/0. Funkce SOUČIN.SKALÁRNÍ je jen příkladem "kde je vhodné" tuto metodu použit, můžete ji použít v libovolných vzorcích, kde obecně chcete nahradit funkci KDYŽ.

Příklad:
Pokud do vzorce uvedete = 3>2, vzorec vrátí PRAVDA.
Pokud, ale do vzorce uvedete = --(3>2), vzorec vrátí 1.

Praktický příklad =SOUČIN.SKALÁRNÍ(--(A1:A7<12);B1:B7) vrátí výsledek 44.

Proč a jak použít dvě znaménka minus ve vzorci

Uvedený příklad a další příklady si můžete stáhnout zde: Nejste přihlášen(a).

print Formát pro tisk

Sdílet článek:

Komentáře rss

Přidat komentář >

Nebyly přidány žádné komentáře.

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

VBA odemknutí a zamknutí sešitu

xlnc • 19.9. 20:24

VBA odemknutí a zamknutí sešitu

Stalker • 19.9. 10:54

VBA odemknutí a zamknutí sešitu

ambraa • 19.9. 10:04

VBA automatické zamknutí buňky s podmínkou

pohis • 17.9. 18:47

Aktivace makra bunkou

Zbygi • 17.9. 14:36

VBA automatické zamknutí buňky s podmínkou

pohis • 17.9. 10:41

VBA automatické zamknutí buňky s podmínkou

Stalker • 17.9. 10:06