Nacházíte se: WALL.czExcel návod › Proč a jak použít dvě znaménka mínus ve vzorci?
Kategorie: Excel návod

Proč a jak použít dvě znaménka mínus ve vzorci?

ExcelPoužití dvou znamének mínus vedle sebe ve vzorci způsobí, že vzorec převede návratovou hodnotu "PRAVDA" na 1 a návratovou hodnotu "NEPRAVDA" na hodnotu 0.

Tato metoda se většinou používá ve vzorcích SOUČIN.SKALÁRNÍ k převedení podmíněných polí, která vrátí hodnotu PRAVDA/NEPRAVDA na 1/0. Funkce SOUČIN.SKALÁRNÍ je jen příkladem "kde je vhodné" tuto metodu použit, můžete ji použít v libovolných vzorcích, kde obecně chcete nahradit funkci KDYŽ.

Příklad:
Pokud do vzorce uvedete = 3>2, vzorec vrátí PRAVDA.
Pokud, ale do vzorce uvedete = --(3>2), vzorec vrátí 1.

Praktický příklad =SOUČIN.SKALÁRNÍ(--(A1:A7<12);B1:B7) vrátí výsledek 44.

Proč a jak použít dvě znaménka minus ve vzorci

Uvedený příklad a další příklady si můžete stáhnout zde: Nejste přihlášen(a).

print Formát pro tisk

Sdílet článek:


Přeposlat článek e-mailem

Komu * Můžete zadat více adres oddělených středníkem
Vaše e-mailová adresa *
Vaše jméno
Kontrola
Připojit vzkaz
Položky označené * jsou povinné

Komentáře rss

Přidat komentář >

Nebyly přidány žádné komentáře.

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Tabulka dovolených 2021

lugr • 15.1. 22:00

Makro na skrytí sloupců v závislosti na název

kalisci • 15.1. 15:33

Rozkopírování dat do listů

Raders486 • 15.1. 15:30

Makro na skrytí sloupců v závislosti na název

elninoslov • 15.1. 14:16

Makro na skrytí sloupců v závislosti na název

kalisci • 15.1. 10:50

Tabulka dovolených 2021

lugr • 14.1. 18:29

Změna hypertextového odkazu po proceduře

Raders486 • 14.1. 16:40