Nacházíte se: WALL.czExcel návod › Součet každého xtého řádku
Kategorie: Excel návod

Součet každého xtého řádku

ExcelUživatelé se poměrně často setkávájí s příklady, kdy potřebují v tabulce sečíst nesouvislou oblast dat nebo každý xtý řádek. Další variantou je případ, kdy se poloha každého xtého řádku v tabulce dynamicky mění.

Může se jednat například o tabulku, kde je uveden datum a potřebujeme sečíst hodnoty za určité dny v týdnu (např. každé pondělí). Jedná se o tabulku, kde po zadání nového měsíce se dny v týdnu posunou (číslo dne je pevné a dny v týdnu se pohybují). V takových případech musí uživatel každý měsíc vzorec ručně upravit (odkazy na buňky posunout).

Součet každého xtého řádku

Součet každého xtého "pohybujícího" řádku lze vyřešit pomocí jediného maticového vzorce. Tento vzorec sečte každý zvolený den v týdnu, bez ohledu na to, na jakém řádku se nachází. Vzorec v buňce D:37:

{=SUMA((DENTÝDNE($B$5:$B$35;2)=SVYHLEDAT(B37;{"pondělí";1|"úterý";2|"středa";3|"čtvrtek";4|"pátek";5|"sobota";6|"neděle";7};2;0))*(D5:D35))}

Vzor vypadá na první pohled složitě, ale není tomu tak. Vysvětlím složení a jak funguje.

  • Hlavní část tvoří vzorec: =SUMA((PODMÍNKA)*(SOUČTOVÁ OBLAST))
  • PODMÍNKA: funkce DENTÝDNE vrátí číslo určující den v týdnu odpovídající zadanému kalendářnímu datu a porovná s podmínkou.
  • SOUČTOVÁ OBLAST: oblast, ve které provádí součet, pokud je PODMÍNKA splněna.
  • Vzorec je nutné zadat jako maticový stiskem kláves Ctrl+Shift+Enter.

Přikládám příklad, který si můžete stáhnout zde. Měsíc a rok můžete měnit v buňkách B3 a B4. Dny v týdnu, které chcete sečíst můžete měnit v buňkách B37 a B38 výběrem ze seznamu.

print Formát pro tisk

Sdílet článek:

Komentáře rss

Přidat komentář >

Nebyly přidány žádné komentáře.

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Nakopírování části textu

Radek-Klepacek • 23.6. 19:42

Nakopírování části textu

elninoslov • 23.6. 19:25

Nakopírování části textu

Radek-Klepacek • 23.6. 15:47

Chyby primitivních maker

Ondry • 23.6. 13:20

Chyby primitivních maker

elninoslov • 23.6. 12:45

Chyby primitivních maker

Ondry • 23.6. 11:50

Rezim kompatibility xls

marjankaj • 23.6. 10:13