Nacházíte se: WALL.czExcel návod › Vzorec pro počítání výskytů textového řetězce
Kategorie: Excel návod

Vzorec pro počítání výskytů textového řetězce

ExcelV tomto článku najdete několik vzorců, které počítají výskyty textových řetězců a znaků v buňce nebo v oblasti buněk.

Otevřete MS Excel nový, prázdný sešit. V novém sešitu vytvořte vzorek dat pro hledání textových řetězců.
A1: Petr, Pavel, Jan A2: Petr, Jan A3: Jan, Pavel A4: Pavel, Petr A5: Jan

1. Počet výskytů textového řetězce v oblasti buněk

Do buňky A8 vložte tento vzorec: {=SUMA(DÉLKA($A$1:$A$5)-DÉLKA(DOSADIT($A$1:$A$5;"Jan";"")))/DÉLKA("Jan")} Uvedený vzorec musí být zadán jako maticový. Vzorec potvrďte stiskem kláves CTRL + SHIFT + ENTER. Vzorec vrátí hodnotu 4, protože text "Jan" se v oblasti vyskytuje čtyřikrát.

2. Počet znaků v buňce

Do buňky A11 vložte tento vzorec: =DÉLKA(A1)-DÉLKA(DOSADIT(A1;"P";"")) Vzorec vrátí hodnotu 2, protože znak "P" se v buňce A1 vyskytuje dvakrát.

3. Počet znaků v oblasti buněk

Do buňky A14 vlože tento vzorec: {=SUMA(DÉLKA($A$1:$A$5)-DÉLKA(DOSADIT($A$1:$A$5;"P";"")))} Uvedený vzorec musí být zadán jako maticový. Vzorec potvrďte stiskem kláves CTRL + SHIFT + ENTER. Vzorec vrátí hodnotu 6, protože znak "P" se v oblasti vyskytuje šestkrát.

4. Počet slov oddělených mezerou v buňce

Do buňky A18 zapište text Průvodce programem Microsoft Excel. Do buňky A17 vložte tento vzorec: =KDYŽ(DÉLKA(PROČISTIT(A18))=0;0;DÉLKA(PROČISTIT(A18))-DÉLKA(DOSADIT(A18;" ";""))+1) Vzorec vrátí hodnotu 4, protože v buňce A18 jsou čtyři slova oddělené mezerou.

5. Vyhledání počtu textových řetězců/znaků pomocí VBA

Spusťte Visual Basic Editor (klávesová zkratka Alt + F11). Vložte nový modul a do modulu zkopírujte níže uvedený VBA kód. Označte myší oblast buněk A1:A5 a spusťte makro (klávesová zkratka Alt + F8): Sub Hledat_Pocet() Dim Pocet As Integer Dim Hledat As String Dim Cell As Object Dim N As Integer Pocet = 0 Hledat = InputBox("Zadej hledané znaky:") If Hledat = "" Then End For Each Cell In Selection N = InStr(1, Cell.Value, Hledat) While N <> 0 Pocet = Pocet + 1 N = InStr(N + 1, Cell.Value, Hledat) Wend Next Cell MsgBox "'" & Hledat & "' se vyskytuje " & Pocet & " x." End Sub Do vstupního formuláře zadejte hledaný znak nebo textový řetězec. Makro vrátí nalezený počet výskytů.

Soubor s příklady vzorců z článku Nejste přihlášen(a).

print Formát pro tisk

Sdílet článek:


Přeposlat článek e-mailem

Komu * Můžete zadat více adres oddělených středníkem
Vaše e-mailová adresa *
Vaše jméno
Kontrola
Připojit vzkaz
Položky označené * jsou povinné

Komentáře rss

Přidat komentář >

, Priklad 1 odpovědět
avatar
Za predpokladu, ze jedno jmeno muze byt v bunce maximalne jednou, muze byt alternativou maticovy vzorec =SUM(--ISNUMBER(SEARCH(E1,$A$1:$A$5))), pripadne nematicove =SUMPRODUCT(--ISNUMBER(SEARCH(E1,$A$1:$A$5)))citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Autofit textu ve sloučených a zalomených buňkách

Chezzy • 21.10. 18:45

Autofit textu ve sloučených a zalomených buňkách

Chezzy • 21.10. 18:42

Autofit textu ve sloučených a zalomených buňkách

Chezzy • 21.10. 18:41

Data z dvoch poli do jedneho

elninoslov • 21.10. 12:07

Data z dvoch poli do jedneho

AL • 20.10. 21:47

Data z dvoch poli do jedneho

eLCHa • 20.10. 21:43

Data z dvoch poli do jedneho

elninoslov • 20.10. 21:25