< návrat zpět

MS Excel


Téma: Součet n-tých řádků rss

Zaslal/a 30.3.2015 20:49

Ahoj lidi! Pokouším se napsat vzorec pro součet hodnot n-tých řádků, daného sloupce v dané oblasti.
Ale buď mi vrací nulu, nebo součet všech řádků. Už jsem se zacyklil a nevím jak dál. Je to vůbec možné vzorcem řešit?

Zaslat odpověď >

#024317
avatar
Už jsem to našel.
http://www.excel-easy.com/examples/sum-every-nth-row.htmlcitovat
icon #024321
eLCHa
Odpověď jste si našel - ale bude fungovat jen pro oblast začínající na prvním řádku (což asi vyhovuje ;) )
Obecné řešení (n je v buňce B1):=SOUČIN.SKALÁRNÍ(A3:A32;(MOD(ŘÁDEK(A3:A32)-MIN(ŘÁDEK(A3:A32))+1;B1)=0)/1)=SUMPRODUCT(A3:A32,(MOD(ROW(A3:A32)-MIN(ROW(A3:A32))+1,B1)=0)/1)citovat
icon #024326
admin
Zkuste se podívat na tento článek http://wall.cz/excel-navod/filtrovani-funkci-soucin.skalarni. Případně ještě přikládám jiný příklad.
Příloha: zip24326_priklad.zip (6kB, staženo 17x)
citovat
#024327
avatar
Pánové díky za reakci. Pravda na "SKALÁRNÍ SOUČIN" stále, pro mou škodu, zapomínám.
A jen nevýznamný dodatek:
=SUMA(A3:A32*(MOD(ŘÁDEK(3:32)-MIN(ŘÁDEK(3:32)-1);B1)=0)){CSE}citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Vytvoření tabulky dovolených excel 2007

MisaKl • 19.9. 11:10

Excel po otevření změní filtry

Pepe123 • 19.9. 9:44

nahodne cisla

mepexg • 18.9. 12:09

nahodne cisla

pavol14pavol • 17.9. 21:46

Nájsť správne číslo a dosadiť novú hodnotu

Alindros • 17.9. 13:21

Nájsť správne číslo a dosadiť novú hodnotu

Alindros • 17.9. 13:15

Nájsť správne číslo a dosadiť novú hodnotu

Alindros • 17.9. 13:13