< návrat zpět

MS Excel


Téma: funkce KDYŽ, A, NEBO rss

Zaslal/a 12.9.2017 12:18

Zdravím, trápím se s funkcí KDYŽ a asi by to chtělo i podmínku NEBO, bohužel nějak mi to hlava nebere. Možná i něco jiného, nevím. Mám nasledující příklad:
V prvním sloupci mám datum zažátku práce
V druhém mám kroky k této práci těch může být max 8
Ve třetím bych potřeboval přiřadit datumy těchto kroků.
Např.:
První den je začátek práce
první krok je +1 den k datu začátku kdy je připraven materiál
druhý krok je např.: SILK tak +2 dny k datu začátku (ten krok může být OFF nebo SILK)
třetí krok je buď +2 dny k datu začátku pokud je ten krok stejný jako předchozí (SILK) nebo +3 dny k datu začátku pokud je to jiný krok (OFF)
čtvrtý krok může být to samé nebo +3 dny k datu začátku

dá se to popsat i tak že pokud je několik kroků po sobě stejných budou se dělat v ten samý den, a když je následující krok jiný dělá se až druhý den a pokud jich je opět několik stejných opět se dělají v ten samý den. bohužel ty kroky mohou být i na střídačku: SILK, OFF, SILK, OFF... nebo SILK, SILK, OFF, SILK, OFF, či OFF, OFF, SILK, SILK, OFF

Příloha: zip37630_kdyz_plus_den.zip (12kB, staženo 8x)
Zaslat odpověď >

#037645
avatar
Na všetky Vaše príklady podľa mňa funguje toto.
Příloha: xlsx37645_kdyz-plus-den.xlsx (11kB, staženo 8x)
citovat
#037650
avatar
Děkuji moc, prfektně vyřešeno.
Jen jsem zapoměl že může nastat varianta kdy mezi kroky nebude nic a pak to hodí chybu #HODNOTA! je to protože v tom řádku kde nic není není ani datum a tak na následujícím řádku je chyba. Vyřešil jsem to úpravou vzorce
z:=KDYŽ(B3="";"";D2+KDYŽ(B3=B2;0;1))
na:=KDYŽ(B3="";D2;D2+KDYŽ(B3=B2;0;1))

a pak přidal podmíněné formátování na řádky bílý text kde nic není

Snad je to tedy správné řešení. Ještě jednou děkuji.citovat
#037652
avatar
Takto by to mohlo byť bez ohľadu na medzery. Jeden vzorec pre všetky riadky. Medzera sa nepovažuje za prerušenie série rovnakých krokov (proste nieje to zmena, nezvyšuje dátum).
Příloha: xlsx37652_kdyz-plus-den.xlsx (11kB, staženo 9x)
citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Generování kódu z buněk + pořadového čísla

freename • 23.11. 17:46

Makra - heslo

Anonym • 23.11. 17:45

Chyba v Excelu?

Vovka • 23.11. 16:30

Práce se dny mezi dvěma daty

marjankaj • 23.11. 16:10

excel vba tisk cyklus for do pdf

titus15 • 23.11. 15:25

excel vba tisk cyklus for do pdf

titus15 • 23.11. 15:23

Práce se dny mezi dvěma daty

spider-x • 23.11. 14:50