< návrat zpět

Obecná diskuse


Téma: zaškrtávací políčko rss

Zaslal/a icon 15.3.2009 13:38

Potřeboval bych poradit s tímto: Mám ovládací prvek formuláře "zaškrtávací políčko" a potřebuji, aby se po jeho zaškrtnutí objevilo v textovém poli "X" a po jeho odznačení se v textovém poli neukázalo nic.


icon icon#000383
admin
Zaškrtávací políčko ve Formátu ovládacího prvku propojte v buňkou (např. A1).

V buňce A1 se následně po zaškrtnutí tlačítka zobrazí PRAVDA a po odškrtnutí NEPRAVDA.

Do buňky B1 zadejte vzorec =KDYŽ(A1=PRAVDA;"X";""). Teď už jen stačí textové pole propojit s buňkou B1, tak že kliknete na textové pole a do Řádku vzorců napíšete =B1.citovat
icon#000387
avatar
OK Děkuji za odpověď!citovat
#005435
avatar
Pokud nemusí být oba prvky přímo v listu, ale je možné je umístit do dialogového okna (UserForm), je čistším řešením tato procedura - metoda zaškrtávacího políčka:
Private Sub CheckBox1_Click()
If CheckBox1.Value = True Then
TextBox1.Value = "X"
Else
TextBox1.Value = ""
End If
End Subcitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Novinky

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Odkaz na buňku

Opičák • 4.8. 1:03

Odkaz na buňku

marjankaj • 3.8. 21:55

provázání několika funkcí

Iska • 3.8. 20:29

Dynamícký RANGE mezi 2 buňkami s názvem

Mars-Ultor • 3.8. 19:40

Odkaz na buňku

Pavlus • 3.8. 19:02

Dynamícký RANGE mezi 2 buňkami s názvem

Pavlus • 3.8. 18:51

provázání několika funkcí

Pavlus • 3.8. 18:50