< návrat zpět

Obecná diskuse


Téma: zaškrtávací políčko rss

Zaslal/a icon 15.3.2009 13:38

Potřeboval bych poradit s tímto: Mám ovládací prvek formuláře "zaškrtávací políčko" a potřebuji, aby se po jeho zaškrtnutí objevilo v textovém poli "X" a po jeho odznačení se v textovém poli neukázalo nic.


icon icon#000383
admin
Zaškrtávací políčko ve Formátu ovládacího prvku propojte v buňkou (např. A1).

V buňce A1 se následně po zaškrtnutí tlačítka zobrazí PRAVDA a po odškrtnutí NEPRAVDA.

Do buňky B1 zadejte vzorec =KDYŽ(A1=PRAVDA;"X";""). Teď už jen stačí textové pole propojit s buňkou B1, tak že kliknete na textové pole a do Řádku vzorců napíšete =B1.citovat
icon#000387
avatar
OK Děkuji za odpověď!citovat
#005435
avatar
Pokud nemusí být oba prvky přímo v listu, ale je možné je umístit do dialogového okna (UserForm), je čistším řešením tato procedura - metoda zaškrtávacího políčka:
Private Sub CheckBox1_Click()
If CheckBox1.Value = True Then
TextBox1.Value = "X"
Else
TextBox1.Value = ""
End If
End Subcitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Novinky

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

vzorce

nospe • 1.11. 0:26

Příčítání hodnoty

tillda • 31.10. 22:11

Sečítání tabulky

tillda • 31.10. 22:08

Příčítání hodnoty

€Ł мσşqμΐτσ • 31.10. 14:41

Příčítání hodnoty

tillda • 31.10. 14:34

Příčítání hodnoty

€Ł мσşqμΐτσ • 31.10. 11:09

otevření *.xls a jeho uložení jako 1 2 3.xls

Yerome1 • 31.10. 9:49