< návrat zpět

MS Excel


Téma: Průměr bez nejvyšší hodnoty rss

Zaslal/a 7.11.2017 18:50

Prosím o pomoc se vzorcem v excelu.
Ve sloupci C mám hodnoty, pomocí LARGE v C23 zjistím nejvyšší hodnotu a rád bych získal aritmetický průměr bez této zjištěné nejvyšší hodnoty. Jak dál? Lze nějak nadefinovat vzorec, aby uměl odstranit x nejvyšších hodnot, např. pokud v C25 zadám 3, pak by se průmět počítal bez 3 nejvyšších hodnot.
Děkuji za tipy

Příloha: zip38301_data-cisteni.zip (7kB, staženo 12x)
Zaslat odpověď >

#038302
avatar
=AVERAGEIF(C2:C19;"<"& LARGE(C2:C19;2))
Aritmetický priemer bez 2 najvyšších hodnôt.

A čo v prípade, že najvyššia hodnota (10) sa vyskytne viackrát?citovat
#038303
avatar
Moc děkuji, dokonce jde tu dvojku nahradit odkazem na buňku, takže to dělá přesně to, co chci.citovat
#038304
avatar
Ak tam budeš mať tri 10 tak ti to urobí priemer bez tých troch 10 a nie iba bez dvoch 10.citovat
#038305
elninoslov
Takýto maticový vzorec (Ctrl+Shift+Enter) Vám to vypočíta tak, že vynechá zadaný počet najvyšších čísel tak, že ak zadáte 3 najvyššie vynechať, ale budú tam rovnaké 4 najvyššie (napr. 4x10), tak vynechá z priemeru iba 3, lebo toľko ste zadal. To len na ilustráciu toho, že je rozdiel či to vynechanie myslíte takto, alebo tak že sa pri zadaní 3 vynechaných, vynechajú 4x10, ďalej sa vynechajú aj napr. 7-ičky, a vynechajú sa aj 5-ky.
=AVERAGE(IF(ROW(A1:INDEX(A:A;ROWS(POCTY)))>C25;LARGE(POCTY;ROW(A1:INDEX(A:A;ROWS(POCTY))))))
=PRŮMĚR(KDYŽ(ŘÁDEK(A1:INDEX(A:A;ŘÁDKY(POCTY)))>C25;LARGE(POCTY;ŘÁDEK(A1:INDEX(A:A;ŘÁDKY(POCTY))))))

POCTY je tá Vaša oblasť, ktorá predpokladám bude dynamická, tak si na to urobte nejaký Definovaný názov.citovat
#038307
avatar
a co prostě

=(SUMA(C2:C19)-MAX(C2:C19))/(POČET(C2:C19)-1)citovat
#038308
avatar

lubo napsal/a:

a co prostě

=(SUMA(C2:C19)-MAX(C2:C19))/(POČET(C2:C19)-1)

No áno, ale ak priemer má byť bez troch najväčších?citovat
icon #038310
admin
A MEDIAN by nestačil? =MEDIAN(C2:C19)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Zaokruhlenie na 15min

Jirka100 • 22.7. 11:24

VBA - zapsaní jména před uložením

Stalker • 21.7. 23:57

Makro - vytváření historie

Merlin99 • 21.7. 16:33

Makro - vytváření historie

Stalker • 21.7. 16:20

Makro - vytváření historie

Merlin99 • 21.7. 15:48

Makro - vytváření historie

Stalker • 21.7. 13:50

Makro - vytváření historie

Merlin99 • 21.7. 12:47