< návrat zpět

MS Excel


Téma: Sčítání kusů podle měsíce rss

Zaslal/a 7.12.2017 15:52

Dobrý den,

mám problém s excelem který nedokážu vyřešit, proto se na Vás obracím s prosbou o radu. Prošel jsem různá fóra a různé návody ale pokaždé se někde zakopu.

Potřebuji aby se mi v buňce O3 zobrazoval součet ze sloupce F vybraných měsíců z buňky O2. Datum podle kterého by se mělo sčítat je ve sloupci H (samo se doplňuje)

Byl by někdo tak hodný a nakopl mě správným směrem?

Příloha: xlsx38673_kniha-objednavek-2018.xlsx (429kB, staženo 7x)
Zaslat odpověď >

#038675
avatar
sumif(měsíc(H:H);měsíc(O2);F:F)
Inak príloha je k ničomu, vzorec je podľa zadania, nie podľa prílohy.citovat
#038676
avatar
Omlouvám se ale nerozumím...citovat
#038677
avatar
asi takto
Příloha: xlsx38677_kopia-38673_kniha-objednavek-2018-1.xlsx (388kB, staženo 11x)
citovat
#038678
avatar
Děkuji za Váš čas 1citovat
#038679
avatar
Nabudúce si aj nejaké dáta vyplň sám. Nikto to za teba robiť nebude.citovat
#038691
avatar
Dalo by sa to aj maticovo bez pomocného stĺpca, ale na celých milión riadkov je to pomalé. Preto si obmedzte oblasť napr. do 6000. Ako píše marjankaj, príloha nekorešponduje presne s popisom. V O2 máte celkovú sumu, sem nezadávate mesiac. Mesiace máte predsa po jednom v Q2:AB2. Tam si dajte do Q2 napr. maticový vzorec (Ctrl+Shift+Enter)
=SUM((IFERROR(MONTH($H$3:$H$6000);0)=COLUMN(A1))*($H$3:$H$6000<>"")*($F$3:$F$6000))
=SUMA((IFERROR(MĚSÍC($H$3:$H$6000);0)=SLOUPEC(A1))*($H$3:$H$6000<>"")*($F$3:$F$6000))

a nakopírujte ho po AB2, a máte mesiace jednotlivo spočítané.

Ak to chcete silou-mocou urobiť podľa popisu, že zrušíte ten vzorec v O2 a nahradíte ho výberom mesiaca, tak v O3 použite predošlý vzorec ale zmente COLUMN(A1)/SLOUPEC(A1)
na O2.

V stĺpci H máte vzorec
=IF(ISTEXT(A3);TODAY();"")
=KDYŽ(JE.TEXT(A3);DNES();"")

ten sa Vám ale nebude dopĺňať ako píšete. Všetky dátumy budú rovnaké. Ak chcete pri vyplnení A zaznamenať čas v H, tak musíte zapnúť Iteračný výpočet (Súbor - Možnosti - Vzorce - Povoliť iteračný výpočet) a vzorec zmeniť napr. na
=IF(A3="";"";IF(H3="";TODAY();H3))
=KDYŽ(A3="";"";KDYŽ(H3="";DNES();H3))

Bezpečnejšie ale je zadávať dátum ručne.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse