< návrat zpět

MS Excel


Téma: Maticový vzorec rss

Zaslal/a 21.3.2018 18:38

lajosPo dlouhé době Vás zdravím a prosím o radu či pomoc.
Pomocí Maticového vzorce se snažím počítat potřebná data.Ale nedaří se.První problém.Data importuju do listu Data1 a nemohu s daty nijak pracovat.Musí zůstat v té struktuře v jaké jsou.Počet sloupců je stejný vždy,počet řádků se mění.Proto jsem nastavil hodnotu na 1000(víc jich nikdy nebude) řádků,ale to nefunguje.V červené bunce vzorec nefunguje,v zelených ano.Co mi uniká?Poradí někdo zkušenější?Dík za případné reakce.Pěkný večer všem.

Příloha: xlsx39935_test1.xlsx (31kB, staženo 7x)
Zaslat odpověď >

#039936
avatar
Ahoj, myslím, že problém máte v listu Data1, sloupci P, řádek 20. Je tam tečka za tisícem, stačí ji vyhodit a jede to v pohodě...citovat
#039937
lajos
Ach jo,taková školácká chyba..děkuju..
A co další červené bunky,proč vzorec nefunguje?Není to už moc parametrů?citovat
#039940
avatar
Maticově vložte =SUMA((Data1!$D$1:$D$1000=$C$2)*(NEBO((Data1!$G$1:$G$1000=$B$5);(Data1!$G$1:$G$1000=$B$6);(Data1!$G$1:$G$1000=$B$7)))*(Data1!$L$1:$L$1000=$B15)*(Data1!$P$1:$P$1000))
Pokud jsem teda správně pochopil myšlenku, že ve sloupci G hledáte shodu s B5 nebo B6 nebo B7.
Ty dva poslední řádky jsou stějně prázdné, B17 a B18 se v datech asi nenachází...citovat
#039941
elninoslov
OR/NEBO v maticových vzorcoch nefunguje. Musí sa použiť +.
Na to prvé ani maticu nepotrebujete, stačí SUMIFS.
Skontrolujte si to, moc som sa tomu nevenoval...
Příloha: xlsx39941_39935_test1.xlsx (32kB, staženo 13x)
citovat
#039942
avatar
S tím or/nebo jsem to nevěděl, na té troše, co jsem to zkoušel to fungovalo, už jsem si o tom něco přečetl, díky.citovat
#039944
elninoslov
Prípadne v tom druhom vzorci môžete namiesto matice SUM/SUMA, použiť obyčajný nematicový variant vzorca. Nahradíte funkciu SUM/SUMA funkciou SUMPRODUCT/SOUČIN.SKALÁRNÍ, a posledné násobenie * nahradíte bodkočiarkou ;

Ono SUMPRODUCT/SOUČIN.SKALÁRNÍ je vlastne tiež matica, len interná, a Vy ju v tomto prípade nemusíte zadávať cez Ctrl+Shift+Enter (v niektorých prípadoch je treba aj SUMPRODUCT zadávať ako maticu, ale na tento nie).citovat
#039982
lajos
Všem děkuji za pomoc při řešení. 1citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Prepínanie údajov po rokoch

Denis • 19.10. 20:42

setřídění vzestupně-sestupně

fortes • 19.10. 18:56

Excel Formulář

pisbo • 19.10. 12:03

Prepínanie údajov po rokoch

Denis • 18.10. 22:37

Excel Formulář

pisbo • 18.10. 17:57

Odeslání dat do souboru v síti a zápis do něj

xlnc • 18.10. 12:09

Excel Formulář

xlnc • 18.10. 11:56