< návrat zpět

MS Excel


Téma: Excel - doplneni bunek od - do rss

Zaslal/a 27.6.2018 10:00

Dobry den.
Prosim, mate nekdo tip na vzorec, ktery by automaticky doplnoval cisla u mnozstvi?
Specialni pozor na B23-B25, kde se navic pridava posledni hodnota i dolu.

Navic,
zvládne nejakou funkci Excel secist automaticky vysledky ve sloupci E?
Ja to udelal polorucne.

UPDATE:
v priloze je mnozstvi3.xls kde je jiz Pavlus tip zaznamenan a je poukazano na problemovy mezivypocet kdyz v B16 bude 1 ks.

Dekuji moc za napady.

Příloha: xlsx40827_mnozstvi3.xlsx (14kB, staženo 17x)
Zaslat odpověď >

#040828
avatar
Děkujeme za zadání, lovínkujeme vás.citovat
#040829
avatar
Výstřel do tmy čistě pro tato vstupní data ;-)...
P.

Např.:
Množství (maticový vzorec):=IFERROR(SMALL(A2:$A$10000; 1); LARGE($A$2:$A$10000; 1))Celkem:=KDYŽ(D2<>D3; SUMIFS(D:D;D:D;D2); "")citovat
#040832
avatar

Pavlus napsal/a:

Výstřel do tmy čistě pro tato vstupní data ;-)...
P.

Např.:
Množství (maticový vzorec):=IFERROR(SMALL(A2:$A$10000; 1); LARGE($A$2:$A$10000; 1))Celkem:=KDYŽ(D2<>D3; SUMIFS(D:D;D:D;D2); "")


Nejprve dekuji.
Matice se chytla, dela co ma, pokud jsou vahy napsany od nejmensiho k nejvetsimu. Pokud prohodime cisla, jiz to moc nefunguje. Ale s tim dokazu zit.
Pro sloupec E (celkem) to funguje pro tento pripad, ale co kdybychom ve sloupci B (množství) - zmenili mnozstvi napr. v B16 na 1 ks. Dostanu tak dalsi mezivypocet ve sloupci G a to bych potreboval "odbourat" - vypocet najednou.
Excel je genialni...i Vase napady.

Dekuji.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Excel s funkci maker

Amor007 • 9.12. 14:22

Vytažení data z webu - VBA

betcup • 9.12. 11:28

Excel s funkci maker

Jiří497 • 8.12. 20:35

Makro Vycenásobné vykopírování dat

misocko • 8.12. 20:20

Excel s funkci maker

Amor007 • 8.12. 7:41

Excel s funkci maker

Jiří497 • 7.12. 21:47

Excel s funkci maker

Amor007 • 7.12. 12:14