< návrat zpět

MS Excel


Téma: sčítání čísel s lomítky rss

Zaslal/a 2.8.2018 17:05

Dobrý den,

prosím o radu zda, příp. jak by v excelu šla sčítat čísla s lomítky (používám při zpracování hotelové stravy,kdy číslo před lomítkem značí dospělé a číslo za lomítkem děti. Př.:
4/2
1/2
2/2
zde potřebuji autom. sumu v tomtéž formátu, tedy 7/6

Děkuji předem za jakoukoli informaci.

Zaslat odpověď >

#041013
elninoslov
Napríklad takto. Maticový vzorec:
=SUM(IFERROR(LEFT(A2:A4;FIND("/";A2:A4)-1)*1;A2:A4*1))&"/"&SUM(IFERROR(MID(A2:A4;FIND("/";A2:A4)+1;LEN(A2:A4))*1;0))
=SUMA(IFERROR(ZLEVA(A2:A4;NAJÍT("/";A2:A4)-1)*1;A2:A4*1))&"/"&SUMA(IFERROR(ČÁST(A2:A4;NAJÍT("/";A2:A4)+1;DÉLKA(A2:A4))*1;0))
Příloha: xlsx41013_pocitanie-porcii-stravy-s-lomitkom.xlsx (9kB, staženo 11x)
citovat
#041032
avatar
Prosím prepáčte, zle som pochopil zadanie a preto sťahujem svoj príspevok.citovat
#041037
elninoslov
Tak ma napadá ešte takéto nematicové riešenie, ktoré nemá problém s vynechaním detských porcií a ráta ich podľa požiadavky, rovnako ako to maticové riešenie.
=SUMPRODUCT(INT(--SUBSTITUTE(A2:A4;"/";",")))&"/"&IFERROR(--REPLACE(SUMPRODUCT(--SUBSTITUTE(A2:A4;"/";",")-INT(--SUBSTITUTE(A2:A4;"/";",")));1;2;"");0)
=SOUČIN.SKALÁRNÍ(CELÁ.ČÁST(--DOSADIT(A2:A4;"/";",")))&"/"&IFERROR(--NAHRADIT(SOUČIN.SKALÁRNÍ(--DOSADIT(A2:A4;"/";",")-CELÁ.ČÁST(--DOSADIT(A2:A4;"/";",")));1;2;"");0)

Mepexg, neviem ako to myslíte, ale nepočíta Vám to správne detské porcie. Pri 4/2, 1/2, 2/2 má dať 6 detských, ale Vám dá 2. No a ak detské raz vynecháme 4/2, 1, 2/2 tak má dať 4 detské, Vám dá chybu.
Příloha: xlsx41037_pocitanie-porcii-stravy-s-lomitkom.xlsx (10kB, staženo 3x)
citovat
#041140
avatar
Děkuji Vám za pomoc, fungují obě možnosti 9citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

DAX DATUM

mepexg • 25.9. 14:39

DAX DATUM

eLCHa • 25.9. 13:55

DAX DATUM

Jeza.m • 25.9. 13:23

DAX DATUM

mepexg • 25.9. 12:24

DAX DATUM

Jeza.m • 25.9. 11:23

Spuštění VBA eventu přepnutím checkboxu

Diphal • 24.9. 15:16

Spuštění VBA eventu přepnutím checkboxu

elninoslov • 21.9. 22:32