< návrat zpět

MS Excel


Téma: Vlastní formát hmotnosti v buňce rss

Zaslal/a 11.2.2019 14:40

Vstup hmotnosti je v kilogramech, méně než 0,1 kg je zobrazeno v gramech, jinak v kg a více než 1000 kg v tunách.

Nedaří se mi sestavit Formát buňky => Vlastní, zkoušel jsem bez úspěchu sestavit limity v hranatých závorkách, nejspíš by musela být vstupní hodnota v gramech, nevěděl by někdo?

Pomocí vzorce:

=KDYŽ(A1<0,1;HODNOTA.NA.TEXT(A1*1000;"0")&" g/ks";KDYŽ(A1<1000;HODNOTA.NA.TEXT(A1;"0,0##")&" kg/ks";HODNOTA.NA.TEXT(A1/1000;"0,0##")&" t/ks"))


Lze nějak nastavit formát čísla na proměnlivý počet míst, aby není-li třeba desetinných míst zobrazoval celé číslo, jinak dle potřeby až tři desetinná místa?
"0,###" bohužel nechá desetinnou čárku za celým číslem.

Předem díky za případnou pomoc.

Zaslat odpověď >

Strana:  « předchozí  1 2
icon #042743
avatar
jj, proste miesto "" tam patri #citovat

Strana:  « předchozí  1 2

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

VBA macro kopírovanie oblasti

elninoslov • 21.8. 0:23

VBA macro kopírovanie oblasti

marjankaj • 20.8. 22:23

VBA macro kopírovanie oblasti

Anonym • 20.8. 18:45

Denní plán směn - poslední úpravy

pk-wall • 20.8. 9:35

Denní plán směn - poslední úpravy

elninoslov • 20.8. 9:30

Denní plán směn - poslední úpravy

pk-wall • 20.8. 7:56

Počet incidentů v roce

elninoslov • 19.8. 14:06