< návrat zpět

MS Excel


Téma: text > číslo=PRAVDA rss

Zaslal/a 26.6.2019 14:35

Může mi prosím někdo vysvětlit podstatu vyhodnocování Excelu při relačním porovnání větší/menší v případě textové a číselné hodnoty mezi sebou?
Zní to možná jako nesmysl, ale v rámci vzorce potřebuji vyhodnotit hodnotu v buňce, jestli vyhovuje současně např. těmto podmínkám: celočíselná hodnota v rozmezí 1 až 10.
Jestliže hodnota v buňce A1 je text, pak relace A1>libovolné číslo je vždy pravdivá...
Děkuji

Zaslat odpověď >

#043598
avatar
Takto ?: =A(A1>=1;A1<=10); =KDYŽ(JE.TEXT(E1);"Text";KDYŽ(JE.ČISLO(E1);"číslo";0))citovat
#043599
avatar
Možná jsem nepopsal problém úplně srozumitelně. Nemůžu se srovnat s tím, že Excel vyhodnotí relaci text>číslo vždy jako pravdivou.
Požadovaný test jsem nakonec postavil takto:=KDYŽ(JE.ČISLO($A$1);($A$1>=1)*($A$1<=10)*($A$1=CELÁ.ČÁST($A$1));0) V případě splnění podmínek vrací "1", jinak "0". Nevím, jestli by to šlo elegantněji.citovat
#043602
avatar
Takhle?
=KDYŽ(A(JE.ČISLO($A$1);$A$1<=10;$A$1>=1);1;0)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

makro platné pre viac rokov

kabaka • 15.11. 17:57

makro platné pre viac rokov

kabaka • 15.11. 17:39

Podmíněný formát - dvě stejná čísla

Jiří497 • 15.11. 16:51

Podmíněný formát - dvě stejná čísla

marjankaj • 15.11. 16:47

Podmíněný formát - dvě stejná čísla

Jiří497 • 15.11. 16:45

Podmíněný formát - dvě stejná čísla

marjankaj • 15.11. 16:29

Podmíněný formát - dvě stejná čísla

Jiří497 • 15.11. 15:44