< návrat zpět

MS Excel


Téma: Odkaz na jiný list makrem rss

Zaslal/a 2.12.2019 15:13

Zdravím,

prosím o pomoc:

Mám sešit, kde na jednotlivých listech jsou recepty. Listy jsou pojmenovány podle názvů receptů (např. „Vanilkové rohlíčky“….)

Na listu mám v řádku 1 názvy jednotlivých listů (názvů receptů)

A ve sloupci A seznam surovin.



Potřeboval bych pomocí makra doplnit vzorce na jednotlivé souřadnice názvu receptu (názvu listu) a suroviny, který by spočítal kolik jednotlivé suroviny je použito v konkrétním receptu.

Použil jsem následující vzorec, ale neumím jej přepsat do makra…. Problém mi dělá odkaz na jednotlivé listy podle názvu receptu - jak zadat list do proměnné?

=SUMIF('Olejové věnečky'!$A$5:$A$50;$A8;'Olejové věnečky'!$C$5:$C$50)/'Olejové věnečky'!$C$2*C$3

Předem děkuji za rady.

Roman

Příloha: zip45156_obrazky.zip (196kB, staženo 6x)
Jméno
Kontrola
Text
  b i u s img code url hr   1 2 3 4 5 6 7 8 9 10

#045159
avatar
A súbor v exceli nevieš priložiť?citovat
#045161
elninoslov
Bez prílohy je to katastrofa. Ale pokus:
=SUMIF(INDIRECT("'"&D$1&"'!$A$5:$A$50");$A8;INDIRECT("'"&D$1&"'!$C$5:$C$50"))/INDIRECT("'"&D$1&"'!$C$2")*D$3
=SUMIF(NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$A$5:$A$50");$A8;NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$C$5:$C$50"))/NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$C$2")*D$3

A nemusíte použiť na to makro.

EDIT: Aj keď myslím, že v receptoch bude ingrediencia uvedená iba raz, a teda netreba SUMIF, ale stačí VLOOKUP/SVYHLEDAT.
=VLOOKUP($A8;INDIRECT("'"&D$1&"'!$A$5:$C$50");3;FALSE)/INDIRECT("'"&D$1&"'!$C$2")*D$3
=SVYHLEDAT($A8;NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$A$5:$C$50");3;NEPRAVDA)/NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$C$2")*D$3
citovat
#045162
avatar

elninoslov napsal/a:

Bez prílohy je to katastrofa. Ale pokus:
=SUMIF(INDIRECT("'"&D$1&"'!$A$5:$A$50");$A8;INDIRECT("'"&D$1&"'!$C$5:$C$50"))/INDIRECT("'"&D$1&"'!$C$2")*D$3
=SUMIF(NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$A$5:$A$50");$A8;NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$C$5:$C$50"))/NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$C$2")*D$3
A nemusíte použiť na to makro.

EDIT: Aj keď myslím, že v receptoch bude ingrediencia uvedená iba raz, a teda netreba SUMIF, ale stačí VLOOKUP/SVYHLEDAT.
=VLOOKUP($A8;INDIRECT("'"&D$1&"'!$A$5:$C$50");3;FALSE)/INDIRECT("'"&D$1&"'!$C$2")*D$3
=SVYHLEDAT($A8;NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$A$5:$C$50");3;NEPRAVDA)/NEPŘÍMÝ.ODKAZ("'"&D$1&"'!$C$2")*D$3


Děkuji za rady, trošku jsem to poupravil a funguje to.
SUMIF jsem použil, protože v receptu se suroviny může vyskytovat vícekrát(když se dezert skládá např z korpusu, ve kterém je cukr a krému, ve kterém je také cukr....)

Makrem jsem to chtěl řešit proto, že konkrétní list generuji celý makrem. Ale už je to na zdárné cestě.

Děkujicitovat
#045167
elninoslov
Priložte prílohu (súbor Excelu) a určo to pôjde ošéfovať.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse