Zdroj: http://wall.cz/excel-navod/soucet-kazdeho-xteho-radku • Vydáno: 14.5.2009 22:05 • Autor: admin

Součet každého xtého řádku

ExcelUživatelé se poměrně často setkávájí s příklady, kdy potřebují v tabulce sečíst nesouvislou oblast dat nebo každý xtý řádek. Další variantou je případ, kdy se poloha každého xtého řádku v tabulce dynamicky mění.

Může se jednat například o tabulku, kde je uveden datum a potřebujeme sečíst hodnoty za určité dny v týdnu (např. každé pondělí). Jedná se o tabulku, kde po zadání nového měsíce se dny v týdnu posunou (číslo dne je pevné a dny v týdnu se pohybují). V takových případech musí uživatel každý měsíc vzorec ručně upravit (odkazy na buňky posunout).

Součet každého xtého řádku

Součet každého xtého "pohybujícího" řádku lze vyřešit pomocí jediného maticového vzorce. Tento vzorec sečte každý zvolený den v týdnu, bez ohledu na to, na jakém řádku se nachází. Vzorec v buňce D:37:

{=SUMA((DENTÝDNE($B$5:$B$35;2)=SVYHLEDAT(B37;{"pondělí";1|"úterý";2|"středa";3|"čtvrtek";4|"pátek";5|"sobota";6|"neděle";7};2;0))*(D5:D35))}

Vzor vypadá na první pohled složitě, ale není tomu tak. Vysvětlím složení a jak funguje.

Přikládám příklad, který si můžete stáhnout zde. Měsíc a rok můžete měnit v buňkách B3 a B4. Dny v týdnu, které chcete sečíst můžete měnit v buňkách B37 a B38 výběrem ze seznamu.