Zdroj: http://wall.cz/excel-navod/negraficky-graf-v-bunkach • Vydáno: 14.6.2009 21:11 • Autor: admin

Negrafický graf v buňkách

ExcelTento návod popisuje, jak vytvořit graf bez průvodce grafu. Jedná se o negrafický graf přímo v buňkách. Hodnoty v grafu jsou zobrazeny jako pruhový graf.

Negrafický graf v oblasti buněk.

Vzorce v sloupcích E a G graficky zobrazují měsíční rozdíly (sloupec D) oproti plánu zobrazením opakovaného symbolu.

Symbol, který budeme zobrazovat a opakovat vybereme z formuláře menu Vložit / Symbol. Můžete vyzkoušet jiný znak nebo místo symbolu můžete použít font Wingdings a opakovaný znak bude představovat vámi zvolené písmeno.

Vložit symbol.

Vstupní hodnoty pro vykreslení grafu budou rozdíly o proti plánu ve sloupci D. Budeme vytvářet složený vzorec, kde nejdříve podmínkou KDYŽ zjistíme jestli se jedná o kladnou nebo zápornou hodnotu. Opakování znaku provedeme použitím funkce OPAKOVAT. Jako opakovaný znak vyberte █ z výše uvedeného formuláře. Vzorce pak budou vypadat následovně:

E2: =KDYŽ(D2<0;OPAKOVAT("█";D2*-100);"")

F2: =A2

G2: =KDYŽ(D2>0;OPAKOVAT("█";D2*100);"")

Označte oblast buněk E2:G2 a zkopírujte vzorce směrem dolů ke spodní úrovni tabulky se vstupními hodnotami. Nakonec naformátujte buňky podle vzoru. Negrafický graf je hotov.