Nacházíte se: WALL.czExcel návod › Proč a jak použít dvě znaménka mínus ve vzorci?
Kategorie: Excel návod

Proč a jak použít dvě znaménka mínus ve vzorci?

ExcelPoužití dvou znamének mínus vedle sebe ve vzorci způsobí, že vzorec převede návratovou hodnotu "PRAVDA" na 1 a návratovou hodnotu "NEPRAVDA" na hodnotu 0.

Tato metoda se většinou používá ve vzorcích SOUČIN.SKALÁRNÍ k převedení podmíněných polí, která vrátí hodnotu PRAVDA/NEPRAVDA na 1/0. Funkce SOUČIN.SKALÁRNÍ je jen příkladem "kde je vhodné" tuto metodu použit, můžete ji použít v libovolných vzorcích, kde obecně chcete nahradit funkci KDYŽ.

Příklad:
Pokud do vzorce uvedete = 3>2, vzorec vrátí PRAVDA.
Pokud, ale do vzorce uvedete = --(3>2), vzorec vrátí 1.

Praktický příklad =SOUČIN.SKALÁRNÍ(--(A1:A7<12);B1:B7) vrátí výsledek 44.

Proč a jak použít dvě znaménka minus ve vzorci

Uvedený příklad a další příklady si můžete stáhnout zde: Nejste přihlášen(a).

print Formát pro tisk

Sdílet článek:

Komentáře rss

Přidat komentář >

Nebyly přidány žádné komentáře.

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Makro na upozornění události

elninoslov • 21.5. 2:38

Sloučení dat dvou sešitů

Scraper • 20.5. 7:55

Sloučení dat dvou sešitů

Stalker • 19.5. 23:06

Makro na upozornění události

parkovec • 19.5. 21:07

plynulá pomalá změna barvy

PavDD • 19.5. 13:47

plynulá pomalá změna barvy

veny • 19.5. 13:23

plynulá pomalá změna barvy

r13 • 19.5. 12:37