Nacházíte se: WALL.czExcel návod › Proč a jak použít dvě znaménka mínus ve vzorci?
Kategorie: Excel návod

Proč a jak použít dvě znaménka mínus ve vzorci?

ExcelPoužití dvou znamének mínus vedle sebe ve vzorci způsobí, že vzorec převede návratovou hodnotu "PRAVDA" na 1 a návratovou hodnotu "NEPRAVDA" na hodnotu 0.

Tato metoda se většinou používá ve vzorcích SOUČIN.SKALÁRNÍ k převedení podmíněných polí, která vrátí hodnotu PRAVDA/NEPRAVDA na 1/0. Funkce SOUČIN.SKALÁRNÍ je jen příkladem "kde je vhodné" tuto metodu použit, můžete ji použít v libovolných vzorcích, kde obecně chcete nahradit funkci KDYŽ.

Příklad:
Pokud do vzorce uvedete = 3>2, vzorec vrátí PRAVDA.
Pokud, ale do vzorce uvedete = --(3>2), vzorec vrátí 1.

Praktický příklad =SOUČIN.SKALÁRNÍ(--(A1:A7<12);B1:B7) vrátí výsledek 44.

Proč a jak použít dvě znaménka minus ve vzorci

Uvedený příklad a další příklady si můžete stáhnout zde: Nejste přihlášen(a).

print Formát pro tisk

Sdílet článek:

Komentáře rss

Přidat komentář >

Nebyly přidány žádné komentáře.

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Tlac s farebneho

ivana1 • 19.6. 22:16

GRAF teploty

Scraper • 18.6. 15:34

Vyhledat dnešní datum když je číslo jako text

veny • 17.6. 13:56

Vyhledat dnešní datum když je číslo jako text

Ontik • 17.6. 12:07

Zaokrouhlování

lubo • 17.6. 12:03

Zaokrouhlování

JoKe • 14.6. 15:19

Zaokrouhlování

Mirek-Kraus • 14.6. 13:52