Příspěvky uživatele


< návrat zpět

Strana:  1 ... « předchozí  6 7 8 9 10 11 12 13 14   další » ... 60

Pane inženýre, je to možné?
Ano, to je možné.
Víte o čem hovořím?
Ne.

Jednou z možností řešení je maticový vzorec.
P.

Např.:
=IFERROR(INDEX($A:$A;SMALL(KDYŽ($B:$B=D$3;ŘÁDEK($A:$A);"");ŘÁDEK($A1));1);"")

Můžeš si vytvořit dynamický seznam, který bude třeba vázaný na zadání aktuálního roku, s tím že vše ostatní se již změní samo. Teoreticky i ten rok lze automatizovat přes funkci DNES (nebo přes nějaký konkrétní datum).

Většina svátků je pevných, a mění se pouze rok, takže ty můžeš zadat přes funkci DATUM. No a na Velikonoční pondělí lze dohledat pěkný vzorec na Googlu (Velký pátek už je pak jen o logice).
P.

Přesně tak, seznam svátků se musí udělat ručně. Zadat jej můžeš kamkoliv.
P.

V tom případě asi nemáš onen svátek zadaný v seznamu svátků. A jak tak koukám na tu přílohu, tak tam ani nikde žádný seznam svátků nevidím...
P.

Koupím pivo každému, kdo chápe zadání... :-D
P.

Asi neporadí ;-).

Žádný řádek s MsgBox jsi neuvedl... Nepíšeš ani, co s Labelem chceš dál dělat...

Křišťálové koule jsou drahé, ne každý má nějakou doma!
P.

Pokud bys tam měl pouze samotná čísla, tak je řešením funkce MIN (počet výskytů pak přes funkci COUNTIFS). Pokud tam vyloženě musíš mít takto ten příznak "dní", tak si můžeš ona samotná čísla vytáhnout do nového sloupce (funkce HODNOTA, ČÁST, NAJÍT). Případně lze také vyřešit přes maticové vzorce...
P.

Př. (maticový vzorec):
=SMALL(HODNOTA(ČÁST($B$2:$B$51;1;NAJÍT(" ";$B$2:$B$51;1)-1));1)

Tak vlož to, co už máš...
P.

Proč jsi nenahrál excelovou přílohu ale jen obrázek?
P.

Lze toho dosáhnout přes funkce KDYŽ, DENTÝDNE a DNES.
P.

Např.:
=KDYŽ(DENTÝDNE(DNES();16)=7;DNES();DNES()-DENTÝDNE(DNES();16))

Tlačítko na klávesnici "Insert"?
P.

A kam jsi ji přidal? ;-)
P.

Důležitou otázkou je, jak se do buňky A1 dostane ona hodnota - důležité pro nastavení (ošetření) podmínky na kopírování (ručně, výpočet...).

Když píšeš, že se mají sloupce přesunout, tak se automaticky i "smažou" z původního listu.

Pak píšeš "data v novém sešitě", ale v předchozí větě mluvíš o přesouvání na nový list. Kam se to tedy má přesouvat?

Rozhodně bys měl vložit přílohu... Jinak řešením je samozřejmě VBA a událost listu.
P.

Předpokládám, že chceš do té buňky vložit přes VBA vzorec.
P.

Např.:
Range("W3").FormulaLocal = "=SUMIFS(V3:V2000;P3:P3000;""<""&A1)"


Strana:  1 ... « předchozí  6 7 8 9 10 11 12 13 14   další » ... 60

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Formulář na procházení záznamů z tabulky

Jiří497 • 26.8. 8:36

Změna seřazení buněk

Jiří497 • 26.8. 8:30

Změna seřazení buněk

nosekpav • 26.8. 8:23

-

nosekpav • 26.8. 8:21

Formulář na procházení záznamů z tabulky

M2M • 26.8. 7:42

Formulář na procházení záznamů z tabulky

Jiří497 • 26.8. 6:17

Formulář na procházení záznamů z tabulky

M2M • 25.8. 21:55