Příspěvky uživatele


< návrat zpět

Strana:  1 ... « předchozí  6 7 8 9 10 11 12 13 14   další » ... 60

Pomohla by příloha, aby bylo přesně vidět, jak máte nastavené formáty.
P.

@elninoslov: První řešení, které mě napadlo, byl pomocný sloupec, stejně jako tebe. Pak jsem to zadal do Googlu, abych si ověřil, jestli není nějaká jiná (lepší) možnost... Každopádně, první odkaz na Googlu, dle linku co jsem dal dole, ten problém přece přímo řeší, ne?
P.

Odkaz:
https://vyuka-excelu.cz/navody/kontingencni-tabulky-prehled-navodu/kontingencni-tabulky-speciality/kontingencni-tabulka-pocitajici-unikatni-jedinecne-hodnoty/

Mimochodem, řešení je na prvním odkazu Googlu ;-)...
P.

Odkaz:
http://lmgtfy.com/?q=jedine%C4%8Dn%C3%A9+hodnoty+po%C4%8Det+kontingen%C4%8Dn%C3%AD+tabulka

Není :-)...
P.

Pane inženýre, je to možné?
Ano, to je možné.
Víte o čem hovořím?
Ne.

Jednou z možností řešení je maticový vzorec.
P.

Např.:
=IFERROR(INDEX($A:$A;SMALL(KDYŽ($B:$B=D$3;ŘÁDEK($A:$A);"");ŘÁDEK($A1));1);"")

Můžeš si vytvořit dynamický seznam, který bude třeba vázaný na zadání aktuálního roku, s tím že vše ostatní se již změní samo. Teoreticky i ten rok lze automatizovat přes funkci DNES (nebo přes nějaký konkrétní datum).

Většina svátků je pevných, a mění se pouze rok, takže ty můžeš zadat přes funkci DATUM. No a na Velikonoční pondělí lze dohledat pěkný vzorec na Googlu (Velký pátek už je pak jen o logice).
P.

Přesně tak, seznam svátků se musí udělat ručně. Zadat jej můžeš kamkoliv.
P.

V tom případě asi nemáš onen svátek zadaný v seznamu svátků. A jak tak koukám na tu přílohu, tak tam ani nikde žádný seznam svátků nevidím...
P.

Koupím pivo každému, kdo chápe zadání... :-D
P.

Asi neporadí ;-).

Žádný řádek s MsgBox jsi neuvedl... Nepíšeš ani, co s Labelem chceš dál dělat...

Křišťálové koule jsou drahé, ne každý má nějakou doma!
P.

Pokud bys tam měl pouze samotná čísla, tak je řešením funkce MIN (počet výskytů pak přes funkci COUNTIFS). Pokud tam vyloženě musíš mít takto ten příznak "dní", tak si můžeš ona samotná čísla vytáhnout do nového sloupce (funkce HODNOTA, ČÁST, NAJÍT). Případně lze také vyřešit přes maticové vzorce...
P.

Př. (maticový vzorec):
=SMALL(HODNOTA(ČÁST($B$2:$B$51;1;NAJÍT(" ";$B$2:$B$51;1)-1));1)

Tak vlož to, co už máš...
P.

Proč jsi nenahrál excelovou přílohu ale jen obrázek?
P.

Lze toho dosáhnout přes funkce KDYŽ, DENTÝDNE a DNES.
P.

Např.:
=KDYŽ(DENTÝDNE(DNES();16)=7;DNES();DNES()-DENTÝDNE(DNES();16))


Strana:  1 ... « předchozí  6 7 8 9 10 11 12 13 14   další » ... 60

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Tisk listu černobíle

Stalker • 28.1. 16:30

Tisk listu černobíle

elninoslov • 28.1. 14:50

Tisk listu černobíle

Dita • 28.1. 14:27

ListBox

elninoslov • 28.1. 13:43

Tisk listu černobíle

elninoslov • 28.1. 13:12

ListBox

ji026441 • 28.1. 13:00

Tisk listu černobíle

Dita • 28.1. 10:25