Příspěvky uživatele


< návrat zpět

Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 60

Dá se to obejít třeba tím, že nebudeš používat formát "Čas", ale vypreparuješ si z toho potřebné části přes textové funkce - tedy zvlášť hodiny, minuty a sekundy, vše převedeš na hodiny, a toto číslo pak bez problému vydělíš potřebnou základnou, abys dostal žádaný průměr.
P.

Jak jsem psal, tak pokud vím, tak to "ručně" nejde...
P.

Je to přesně tak jak píšeš, dokonce to je přesně takto napsané i v té hlášce, co hází Excel, když se pokusíš rozbalit souhrn v zamčeném listu. Ve standardní uživatelské nabídce toto Excel neumožňuje.

Nicméně se to dá obejít makrem. Slouží k tomu vlastnost listu "EnableOutlining", kterou je potřeba nastavit na "True". Níže uvádím ukázku kódu, který uzamkne List1, nicméně dovolí uživateli sbalovat/rozbalovat souhrny.
P.

Př.:
Sub Zamknout_list_s_povolenim_souhrnu()

With Worksheets(List1.Name)
.Protect Password:="", Userinterfaceonly:=True
.EnableOutlining = True
End With

End Sub

Těžko říct, k čemu to bude přesně sloužit, nicméně lze vyřešit například přes vzorce.
P.

Viz příloha:

@Rejpal: Moc díky, už chápu kde je problém a jak jej vyřešit. S tímto jsem se ještě nesetkal, tak mě to zmátlo.

Díky i ostatním za reakce ;-).
P.

@Rejpal: Verzi Excelu bych chápal, ale mám to uložené oboje jako xlsx, a přitom mám v každém sešitu jiné rozložení barev na paletě.

@Stalker: Můžeš prosím přiblížit? Už mě to vytáčí, protože mi takto chodí soubory od jednoho nezbedy, a pořád na to nemůžu přijít ;-).

Potřeboval bych nějak změnit paletu v souboru č.2 na paletu ze souboru č.1.

Viz příloha:

Pokud má to makro nějakou logiku, tak procenta (minimálně orientačně) zobrazit lze. Dle selského rozumu například při zápisu hodnot do 100 buněk bude po zapsání 40. buňky hotovo 40 %.
P.

Je nějaký důvod, proč to řešit makrem?
Tady stačí klidně obyčejný vzorec - funkce CONCATENATE nebo spojení řetězců přes ampersandy (&).
Případné rozdělení do více buněk zvládne s klidem například funkce ČÁST.
P.

Jednou z možností je využití kombinace funkce INDEX a ŘÁDEK.
P.

Např.:
=INDEX(A:A; ŘÁDEK(A1)*2-1; 1)
=INDEX(A:A; ŘÁDEK(A1)*2; 1)

Řešením je funkce SVYHLEDAT (a příslušný číselník s daty a jmény/svátky).
P.

Výstřel do tmy čistě pro tato vstupní data ;-)...
P.

Např.:
Množství (maticový vzorec):=IFERROR(SMALL(A2:$A$10000; 1); LARGE($A$2:$A$10000; 1))Celkem:=KDYŽ(D2<>D3; SUMIFS(D:D;D:D;D2); "")

A co řešení přes sdílený sešit a zabudované sledování změn přímo v Excelu?
P.

Nemusí se jednat o souvislou oblast.
P.

Např.:
=QUARTIL.INC((A1:A10;B1:B10);0)

Je míněn pokles ceny vždy proti minulému měsíci?

Pokud ano, tak to vyřeší jednoduchá podmínka v pomocném sloupci s výstupem 1 nebo 0 a následný součet těchto čísel.

Případně lze použít maticové řešení, principiálně třeba takto:{=SUMA(KDYŽ(B3:B13<B2:B12;1;0))}P.

Principiálně lze řešit například takto:
Private Sub CommandButton1_Click()
Dim zdrojovy_radek As Long
Dim cilovy_radek As Long

zdrojovy_radek = InputBox("Zadejte číslo řádku:")
cilovy_radek = Sheets(List2.Name).Cells(Rows.Count, 1).End(xlUp).Row + 1

Sheets(List2.Name).Cells(cilovy_radek, 1) = Sheets(List1.Name).Cells(zdrojovy_radek, 1)
Sheets(List2.Name).Cells(cilovy_radek, 2) = Sheets(List1.Name).Cells(zdrojovy_radek, 2)
Sheets(List2.Name).Cells(cilovy_radek, 3) = Sheets(List1.Name).Cells(zdrojovy_radek, 6)

End Sub
P.


Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 60

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Formulář na procházení záznamů z tabulky

Jiří497 • 26.8. 8:36

Změna seřazení buněk

Jiří497 • 26.8. 8:30

Změna seřazení buněk

nosekpav • 26.8. 8:23

-

nosekpav • 26.8. 8:21

Formulář na procházení záznamů z tabulky

M2M • 26.8. 7:42

Formulář na procházení záznamů z tabulky

Jiří497 • 26.8. 6:17

Formulář na procházení záznamů z tabulky

M2M • 25.8. 21:55