Příspěvky uživatele


< návrat zpět

Strana:  1 ... « předchozí  2 3 4 5 6 7 8 9 10   další » ... 58

Vlož nějakou přílohu, mrkneme na to ;-)...
P.

Podívej se na parametry funkce ODKAZ, tam přímo nastavuješ, do jakého řádku a sloupce se odkazuješ.
Za předpokladu, že bys chtěl vzorec roztahovat z A1 do dalších buněk, si lze případně pomoci funkcemi ŘÁDEK a SLOUPEC, buňku K8 pak dát samozřejmě absolutním odkazem ($K$8).
P.

Např.:
=NEPŘÍMÝ.ODKAZ(ODKAZ(ŘÁDEK(A1); SLOUPEC(A1); 4; 1; HODNOTA.NA.TEXT(EDATE($K$8;-1);"mmmm") & " " & ROK(EDATE($K$8;-1))); PRAVDA)

1.) Tak rozhodně to jde, v Excelu jde prakticky všechno ;-).
2.) Odkázat se na předchozí list lze určitě i přes vzorce, zvlášť když dle přílohy budou mít listy jasnou logiku názvu.

Pro tvůj konkrétní případ by šlo použít například následující: Díval jsem se, že tam máš vždy datum konkrétního měsíce v určité buňce = K8. Z této buňky si můžeš tedy vytvořit název předchozího listu a přes funkce NEPŘÍMÝ.ODKAZ a ODKAZ se odkázat na konkrétní buňku.

Například v listu leden 2018 se lze odkázat na list prosinec 2017 na buňku A1 tímto vzorcem (předpokladem je, že máš názvy listů včetně diakritiky):
=NEPŘÍMÝ.ODKAZ(ODKAZ(1; 1; 4; 1; HODNOTA.NA.TEXT(EDATE(K8;-1);"mmmm") & " " & ROK(EDATE(K8;-1))); PRAVDA)P.

Zkus využít filtru přímo v "Pole kontingenční tabulky".
P.

Řešením může být funkce COUNTIFS a filtr dle počtu výskytů.
P.

Řešením může být spojování řetězců přes ampersand.
P.

Např.:
Sheets("List1").Range("A1").Value & "*.jpg"

Karta Data / Text do sloupců.
P.

Jednou z možností je přidat nějakou podmínku (třeba hodnota konkrétní buňky), která by se pokaždé v makru testovala.
P.

To podle mě bez makra nepůjde.
P.

Jedno z možných řešení viz níže - roztáhnout vzorec od D1.
P.

Př.:
=KDYŽ(B1<>""; "B" & COUNTIFS($B$1:B1; "<>"&""); KDYŽ(C1<>""; "C" & COUNTIFS($C$1:C1; "<>"&""); ""))

Zkombinuj to, co jsem poslal já, s tím co poslal lubo, a máš hotovo ;-)...
P.

Format:="#,##0.00"Nicméně si nejsem jistý, jak to bude vhodné pro tento případ, kdy to máš v události TextBox_Change...
P.

Obávám se, že univerzální název pro ni zatím není.
Já jí říkám tabulka s předdefinovaným stylem (formátem).
P.

Bez přílohy?
P.

Mě to propojení ukazuje...
P.


Strana:  1 ... « předchozí  2 3 4 5 6 7 8 9 10   další » ... 58

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Kopírovanie textu do neprázdnej bunky

elninoslov • 13.11. 1:22

WebBrowser

Palooo • 12.11. 14:00

WebBrowser

jardik • 11.11. 16:20

Kopírovanie textu do neprázdnej bunky

kabaka • 11.11. 16:07

Kopírovanie textu do neprázdnej bunky

elninoslov • 11.11. 15:56

Podmíněné formátování - formáty buněk

marjankaj • 11.11. 11:29

Kopírovanie textu do neprázdnej bunky

kabaka • 11.11. 10:24