Příspěvky uživatele


< návrat zpět

Strana:  1 2 3 4 5 6 7 8 9   další » ... 47

funguje ale musím si do prázdných buněk ve sloupci C vložím mezery čeho se chci vyhnout

Tak proč ve vzorci hledáš mezery a neupravíš si ho podle toho druhého?

Napadlo mě tohle hulvátský řešení:
=ČÁST(SUMA(A1:B1);1;KDYŽ(MOD(SUMA(A1:B1);1)<>0;5;4))*1Otestuj zda vrací očekávané výsledky.

S výpisem do okna immediate
Debug.Print Worksheets("JmenoListu").Index

S načtením hodnoty do proměnné
i = Worksheets("JmenoListu").Index

Můžeš použít maticový vzorec (jeho zadání se ukončí trojkombinací CTRL+SHIFT+ENTER. Do buňky J1 se zadá kýžený rok. Rozsah buněk si uprav podle svého.
=SUMA((C1:C3="Incident1")*(ROK(G1:G3)=J1))
Nebo se dá použít funkce součin.skalární - není nutné zadávat maticově.
=SOUČIN.SKALÁRNÍ((C1:C3="Incident1")*(ROK(G1:G3)=J1))

Liší se proto, že sem měl zobrazené pouze dvě desetinná čísla. Tedy číslo bez zaokrouhlení vypadá takto
43679,7315856482

Jinak poslední otázce nerozumím, jak si dospěl k názoru, že tebou udávaná hodnota se má zobrazovat zrovna jako zvolené datum?

Edit: uvedené číslo se vzalo z tvého data 2.8.2019 .....

Edit2: Studuj
https://office.lasakovi.com/excel/funkce/ms-excel-datum-a-cas/
http://web.natur.cuni.cz/~jmakov/ExcelStranky/DatumCas.html

Co kdybys poskytnul ten vzorek dat jak žádá elnino, místo toho spamování a zakládání dalších dotazů na jiných poradnách

Vlastní formát buňky rrrr.mm.dd h:mm:ss
Jinak tomuto datu a času odpovídá číslo 43679,73

Tak sem si s tím nějakou dobu hrál, bohužel výsledek není ideální => je to pomalé jak sviňa 7. Na nic lepšího sem nepřišel. Vyčkej na někoho dalšího.

Přikládám svůj pokus, řeší požadavek vrácení sloupců do původního stavu (opětovným spuštěním makra).
Sub UpravSloupce()
Dim SloupceH As String
Dim SloupceW As String

SloupceH = "C1, E1, G1, I1, K1, M1, O1, Q1, S1, U1, W1, Y1"
SloupceW = "B1, D1, F1, H1, J1, K1, N1, P1, R1, T1, V1, X1"

Range(SloupceH).EntireColumn.Hidden = True = Not Range(SloupceH).EntireColumn.Hidden = True

With Range(SloupceW)
If .ColumnWidth = 20.71 Then
.ColumnWidth = 18.71
Else
.ColumnWidth = 20.71
End If
End With
End Sub

Samozřejmě, že šlo. Jen tak v rychlosti bez optimalizace.

Ověření dat nenabízí tuto funkcionalitu.
Možné řešení viz: https://www.youtube.com/watch?v=6ZHR8TFK1rg

Já taky ne, protože neznám strukturu dat. Obecně co hodnota to vzorec (pravděpodobně s rozdílným číslem sloupce).

Funkce SVYHLEDAT (VLOOKUP), nebo INDEX a POZVYHLEDAT (MATCH) to podle struktury dat na druhém listě.

Ne u mě to chybu nehlásí (Excel 2016). Možná popiš co se souborem tvoříš od jeho otevření. Několikrát sem řádky vkládal i mazal, a jak už sem psal nepodařilo se mi chybu nasimulovat.

Bohužel víc neporadím, nedaří se mi nasimulovat chybu. K té funkci fotoaparátu - co takhle místo toho použít kukátko?


Strana:  1 2 3 4 5 6 7 8 9   další » ... 47

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

nahodne cisla

mepexg • 18.9. 12:09

nahodne cisla

pavol14pavol • 17.9. 21:46

Nájsť správne číslo a dosadiť novú hodnotu

Alindros • 17.9. 13:21

Nájsť správne číslo a dosadiť novú hodnotu

Alindros • 17.9. 13:15

Nájsť správne číslo a dosadiť novú hodnotu

Alindros • 17.9. 13:13

Nájsť správne číslo a dosadiť novú hodnotu

Alindros • 17.9. 11:00

nová registrace

kabaka • 17.9. 10:50