< návrat zpět

MS Excel


Téma: vzorec pro výpočet pouze nočních hodin rss

Zaslal/a 1.6.2013 10:15

Prosím o pomoc při sestavení vzorce pro výpočet pouze nočních hodin.začátek směny 17:45 konec 6:00 noční hodiny začínají od 22:00-6:00.díky 1

Příloha: rar13592_vypocet-nocnich-hodin.rar (8kB, staženo 78x)
Zaslat odpověď >

Strana:  1 2 3   další »
#013593
Opičák
vyber si něco z tohoto
Příloha: zip13593_nocni.zip (10kB, staženo 142x)
citovat
#013599
Opičák
Ve tvém příkladu není specifikováno od kdy do kdy je přestávka, tudíž je-li skutečně v případě třeba 16 hodinové šichty v době noční směny. Měl by tam být čas přestávky od do, aby se vědělo, kam ji zařadit.citovat
#013605
avatar
Přestávka je 0:00-0:30 takže se přestávka odečítá z těch nočních hodin.citovat
#013607
Opičák
možná takto

některé tvoje vzorce jsem upravil, protože někde jsi počítal s denní hodinovou hodnotou 24 a jinde 1. Ted je všude uvažována hodnota 24 hodin jako 1.
Příloha: zip13607_vypocet-nocnich-hodin-1.zip (11kB, staženo 126x)
citovat
#013608
avatar
Díky moc takhle je to super 1citovat
#013609
avatar
Přeci jen se ještě naskytla nějaká chyba.Při součtu hodin při vzorečku =SUMA(F4:F34) to vypočte nesmysl i ve sloupci G a H.
Příloha: rar13609_mesicni-pracovni-vykaz.rar (10kB, staženo 50x)
citovat
#013610
Opičák
večer se na to mrknucitovat
#013611
Opičák
Původní vzorec byl pouze pro vyhodnocení nočních, tudíž, když se tam octla ranní nebo odpolení, počítal podivně. Přidal jsem dva skryté sloupce pro další vyhodnocení.
Příloha: zip13611_kopie-mesicni-pracovni-vykaz2.zip (15kB, staženo 68x)
citovat
#013612
avatar
Ten sloupec Noční byl vpoho po úpravě počítal i těch 15 minut z ranní ale od nočních se někde neodečetla přestávka.ale mě nejde do hlavy proč to nechce spočítat celkem hodin za celej měsíc je to označený červeně.
Příloha: rar13612_mesicni-pracovni-vykaz.rar (11kB, staženo 74x)
citovat
#013613
Opičák
Aha, to je pouze formátem čísla. Tento formát ignoruje násobky 24 hodin a zobrazuje jen zbytek.
Zvol jiný formát času. ten co píše v prvním čísle větší číslo než 24. Třeba 37:30:35citovat

Strana:  1 2 3   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Formát čísla

JoKe • 24.2. 17:58

Menu VBA editoru v čínštině

paveku • 24.2. 17:40

Zjednodušení kódu - kopírování z listu do listu

Jiří497 • 24.2. 14:51

Jak vypsat určité hodnoty ze sloupce

Poseidon • 24.2. 12:13

Menu VBA editoru v čínštině

Barth • 24.2. 10:30

Vyhledání poslední obsazené buňky

elninoslov • 24.2. 9:59

Formát čísla

marjankaj • 24.2. 9:57