< návrat zpět

MS Excel


Téma: proměnná ve vzorci rss

Zaslal/a 6.3.2015 23:58

Umím do buňky pomocí makra vložit vzorec.
Range("I12").Select
ActiveCell.FormulaR1C1 = "=SUM(R[-5]C:R[-3]C)"

Nemůžu ale přijít na to, abych -5 a -3 měl jako
proměnnou x a y.

Může mi někdo poradit ?

Díky Laďa

Zaslat odpověď >

Strana:  1 2   další »
icon #024011
eLCHa
zbrucha
"=SUM(R[" & x & "]C:R[" & y & "]C)"citovat
icon #024127
eLCHa
není začcitovat
#024202
avatar
Ještě jednou díky.citovat
#044818
avatar
Prosím poraďte:

Potřebuji do buněk ve sloupci H vložit pomocí makra vzorec =SVYHLEDAT() s proměnnou "x", kde proměnná "x" obsahuje číslo řádku.

Zkusil jsem tento výraz: "=SVYHLEDAT(H" & x & ";Zákazníci!$A$2:$C$1000;2;NEPRAVDA)", ale nefunguje to.

Nefunguje mi dokonce ani verze bez proměnné, třeba: "=SVYHLEDAT(H30;Zákazníci!$A$2:$C$1000;2;NEPRAVDA)".

Napíše mi to "Run-time error '1004' Aplication-defined or object-defined error

Přitom když do těch úvozovek uzavřu jiný vzorec(třeba "=ROW()"), zapíše se do buněk bez problémů.

Kde je chyba?

Předem moc dík za radu.citovat
#044819
avatar
Pardon, nevkládám do sloupce H, pouze z něj beru první hodnotu do vzorce...citovat
#044820
avatar
A neskúšal si na miesto stredníka použiť čiarku?citovat
#044821
avatar
Teď jsem to vyzkoušel, díky. V makru mám tedy ve vzorci čárky, vzorec se tentokrát zapíše (úspěch!) a čárky se v tabulce automaticky změní na středníky. Takže vzorec je již v buňce zapsaný správně, nicméně vrací mi #NÁZEV? Ale když dám kurzor do editovacího řádku a jen stisknu ENTER, vzorec najednou začne fungovat (!), i když zůstal úplně stejný... Co s tím? Potřeboval bych, aby fungoval hned, bez toho enteru... 1citovat
#044822
avatar
Má prosím někdo zkušenost s tímto pozoruhodným úkazem, že vzorec napsaný v makru s čárkami se do tabulky zapíše správně se středníky, ale nefunguje, a fungovat začne až poté, co se nezměněný jen odentruje?

Díkycitovat
#044823
Stalker
Nemělo by být ve VBA spíše VLOOKUP než SVYHLEDAT ?!citovat
#044824
elninoslov
Je dobré vo VBA vkladať EN ekvivalent vzorcov. Každý potom vie o čo ide. (EN funkcie aj EN oddeľovače)
Range("A" & x).Formula = "=VLOOKUP(H" & x & ",Zákazníci!$A$2:$C$1000,2,FALSE)"
Ale môže vkladať aj CZ/SK názvy a oddeľovače:
Range("A" & x).FormulaLocal = "=VLOOKUP(H" & x & ";Zákazníci!$A$2:$C$1000;2;FALSE)"
Range("A" & x).FormulaLocal = "=SVYHLEDAT(H" & x & ";Zákazníci!$A$2:$C$1000;2;NEPRAVDA)"

Obdobne aj štýl R1C1citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

COUNTIF funkce

elninoslov • 4.8. 17:49

COUNTIF funkce

MilaF • 4.8. 16:47

Excel - číslo začíná 0

Mati • 4.8. 14:40

Excel - číslo začíná 0

elninoslov • 4.8. 12:20

Excel - číslo začíná 0

Mati • 4.8. 12:06

Převod desetiného čísla na hodiny a minuty

eLCHa • 4.8. 11:15

Převod desetiného čísla na hodiny a minuty

elninoslov • 4.8. 11:00