< návrat zpět

MS Excel


Téma: Podmíněné formátování (státní svátky) rss

Zaslal/a 11.1.2016 17:28

Merlin99Zdravim vsechny
chci se zepat je mozny tak jako jdou zviraznit vikendy, tak zviraznit červeně statni svatky za pomoci podmineneho formatovani.. viz priloha

Příloha: rar29166_dovolena.rar (11kB, staženo 105x)
Zaslat odpověď >

Strana:  1 2   další »
#029170
avatar
Použij WORKDAY.INTLcitovat
#029171
Merlin99
Děkuji za nakopnutí, ale priznavam ze v podminenem formatovani tento vzorec nejsem schopnej pozit...citovat
#029175
avatar
Třeba

=WORKDAY.INTL(A1-1;1;"0000000";Tabulka s datumy)<>A1

nebo

=SVYHLEDAT(A1;$C$1:$C$2;1)=A1citovat
#029177
elninoslov
Vyskúšajte toto. Je to taká "berlička", keďže pôvodný zámer s maticovou konštantou s aktuálne počítaným rokom nevyšiel, lebo do konštanty nejde vložiť vzorec, a pomocná tabuľka sa tiež nedá použiť, keďže nie je možné do nej vkladať rok, keď nevieme, či bude tabuľka napr pokračovať ďalším rokom, atď., tak som vydumal pomocný reťazec. Mrknite si podmienený formát.
EDIT: Napísal som to minútu po Lubovi, opäť som to nestihol :). Každopádne som zistil, že som zabudol v prílohe zbytočný pokusný list "Svatky" - NIEJE potrebný, tak si ho zmažte. Aktualizovaná príloha.
Příloha: rar29177_dovolena.rar (11kB, staženo 166x)
citovat
#029180
Opičák
je to jednoduché, pokud máte seznam svátků. Pokud se tento nachází v A1:A12, pak stačí do buňky s datem (zde ve vzorci G9) dát podmíněný formát (vzorec) a roztáhnout do celého kalendářního roku.

=JE.ČISLO(POZVYHLEDAT(G9;$A$1:$A$12;0))citovat
#029181
elninoslov
To ale nebude fungovať, tak ako som písal, keď budú dáta z viacerých rokov.citovat
#029182
Opičák
Ale Merlin99 se nedotazoval na viceletý kalendář. Nahodil nějakou tabulku a v ní to jde, pokud se změní rok, změní se automaticky i Velikonoční datum. Ostatní jsou pořád stejný.citovat
#029184
avatar

elninoslov napsal/a:

To ale nebude fungovať, tak ako som písal, keď budú dáta z viacerých rokov.


A co brání doplnit tabulku o svátky pro další roky?citovat
#029186
avatar
Na výpočet dátumu veľkej noci predsa existujú vzorečky.
Niečo takéto napríklad
=DOLLAR(("4/"&B4)/7+MOD(19*MOD(B4;19)-7;30)*14%;)*7-5citovat
#029187
elninoslov
@ lubo: nič, samozrejme to nieje problém. Ale keďže sa do tabuľky sviatkov len tak nezasahuje, tak je zbytočný ďalší list, alebo tabuľka.

@ marjankaj: samozrejme, veď ten vzorec na výpočet veľkej noci v tom mojom podmienenom formátovaní mám.

@ Opičák: viď 2. veta pre "lubo" - nezavadzia tabuľka.citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Výpočet data narození

marjankaj • 20.1. 11:45

Výpočet data narození

Anonym • 20.1. 11:40

Výpočet data narození

marjankaj • 20.1. 11:00

Podbarvení buňky z jiného listu

Marekh • 20.1. 10:21

ActiveX - prvek ComboBox

OB • 20.1. 8:09

Výpočet data narození

JOHAN • 20.1. 6:30

ActiveX - prvek ComboBox

elninoslov • 20.1. 1:02