< návrat zpět

MS Excel


Téma: Vyhledání hodnoty v tabulce rss

Zaslal/a 29.6.2016 7:14

Zdravím, prosím poraďte
mám danou tabulku časů běhů na 100 metrů s přesností 0,1 s. Každému dosaženému času odpovídá daný počet bodů.Potřebuji vzorec, který po vyplnění času přiřadí určený počet bodů. Podrobnosti v příloze. Děkuji.

Příloha: rar31906_bodova-tabulka.rar (8kB, staženo 10x)
Zaslat odpověď >

#031925
elninoslov
Napr.:
=IFERROR(INDEX($C$4:$C$13;COUNTIF($B$4:$B$13;"<"&H4)+1);0)
=CHYBHODN(INDEX($C$4:$C$13;COUNTIF($B$4:$B$13;"<"&H4)+1);0)

S Vašimi bodovými hodnotami čo tam máte, to ale nesedí. Tie Vaše hodnoty nespĺňajú podmienky, alebo som ich nepochopil správne. Ja to chápem tak, že časy v B sú "do, vrátane".citovat
#031946
avatar
Díky za odpověď
Posílám trochu upravené, aby bylo zřejmé, jak má tabulka počítat.
Příloha: rar31946_bodova-tabulka.rar (9kB, staženo 11x)
citovat
#031959
elninoslov
Som len na mobile, robí sa mi strašne zle. Vôbec ste to neobjasnil. Časy v stĺpci B sú najhoršie za aké dostane pretekár body v riadku v stĺpci C? Nepozdávajú sa mi niektoré hodnoty v stĺpci I. Keď má niekto horší čas ako ako posledný z B tak by mal dostať 0, nie? Vysvetlite to o celý rád lepšie - podrobnejšie. A hlavne aspoň okomentujte vzorec, čo som Vám poslal, nech vieme kedy vracia zlú hodnotu ...citovat
#031960
avatar
OK, posílám koment, vyznačeno červeně.
Příloha: rar31960_bodova-tabulka.rar (10kB, staženo 10x)
citovat
#031967
elninoslov
Tak vo vzorci zmente
"<" na "<=" a máte želané hodnoty
prípadne, ak to chcete roztiahnuť aj na riadky kde niesú pretekári, ale chcete tam mať prichystaný vzorec, tak ho obalte do IF
=IF(G4="";"";IFERROR(INDEX($C$4:$C$13;COUNTIF($B$4:$B$13;"<="&H4)+1);0))
=KDYŽ(G4="";"";CHYBHODN(INDEX($C$4:$C$13;COUNTIF($B$4:$B$13;"<="&H4)+1);0))
citovat
#031979
avatar
Funguje jak má. Díky moc.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse