< návrat zpět

MS Excel


Téma: Jednorázové seřazení tabulky rss

Zaslal/a 13.3.2018 19:35

Má někdo nápad jak seřadit tabulku v příloze?
Začátek je dobře, chyba je např. ta, že řádek 82 patří za řádek 54
nebo je třeba prohodit řádky 123 a 124

Není toho mnoho, šlo by to udělat ručně stručně, ale proč si neulehčit. Ale nevím jak. Měl by někdo nějaký nápad?.

Tabulku bych chtěl seřadit jednou. Další seřazení by bylo vhodné za rok dva.
Jedná se čistě o estetickou záležitost. Na další funkčnost pořadí záznamů nemá žádný vliv.
A má cenu to tedy řešit?

Sloupců je asi 12, pro ilustraci jen pár.
Druhý sloupec označuje vazbu na ten první, vždy stejná čísla patří k sobě.
Sloupec A je "rodič" sloupec B jsou "potomci"
Sloupec C- "aaa" je vždy rodič, "bbb" je vždy potomek.

A co dál? Bude vhodnější řešit vazbu rodič-> potomek jinak?
Záznamy budou přibývat tempem zhruba 20 řádků ročně.

Příloha: xlsx39824_vzor.xlsx (19kB, staženo 10x)
Jméno
Kontrola
Text
  b i u s img code url hr   1 2 3 4 5 6 7 8 9 10

#039825
avatar
Já jsem si vytvořil 2 pomocné sloupce.
V prvním:
=KDYŽ($B2="";$A2;$B2)
druhý sloupec
=KDYŽ($B2="";0;$B2)

Hodnoty jsem zkopíroval do sloupce A B a setřídil podle sloupce A a B.

A asi přejdu na systém značení
rodič: 1.0 (1 sloupec A, 0 ve sloupci B)
potomci: 1.1
1.2
1.3

další 2.0
2.1
2.2
Příloha: xlsx39825_39824_vzor.xlsx (23kB, staženo 6x)
citovat
#039826
elninoslov
Možno to pôjde aj jednoduchšie, no raz za 2 roky tú jednu minútu obetujete nie ? Popis v prílohe.
Příloha: xlsx39826_39824_vzor.xlsx (23kB, staženo 7x)
citovat
#039830
avatar
Díky za nápad.

Asi jsem první příspěvek špatně napsal.
Za dobu, než jsem udělal vzorový příklad a popsal problém, tak bych to možná ručním seřazením mohl mít dávno hotové 1

Posledně jsem se z diskuze dozvěděl o FREQUENCY a histogramu v Analytických nástrojích, o čemž jsme do té doby nevěděl.

Tak jsem si říkal, že bych se na tomto mini problému mohl třeba něčím novým inspirovat.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

VBA odemknutí a zamknutí sešitu

xlnc • 19.9. 20:24

VBA odemknutí a zamknutí sešitu

Stalker • 19.9. 10:54

VBA odemknutí a zamknutí sešitu

ambraa • 19.9. 10:04

VBA automatické zamknutí buňky s podmínkou

pohis • 17.9. 18:47

Aktivace makra bunkou

Zbygi • 17.9. 14:36

VBA automatické zamknutí buňky s podmínkou

pohis • 17.9. 10:41

VBA automatické zamknutí buňky s podmínkou

Stalker • 17.9. 10:06