< návrat zpět

MS Excel


Téma: Svyhledat pomoc rss

Zaslal/a 12.7.2019 8:14

Ahoj, hledám pomocí funkce SVYHLEDAT poslední hodnotu ve sloupci pomocí =SVYHLEDAT(9,9999999999E+307;A:A;1)
Potřeboval bych to ale upravit tak že budu hledat 2 od konce, 3 od konce až po 5 od konce. Je to možné ?

Zaslat odpověď >

#043731
avatar
ale toto zadání vrátí vždy hledané číslo 9,9999999999E+307

asi nemá být rozsah A:A a vracená hodnota ze sloupce 1citovat
#043732
avatar

Anonym napsal/a:

ale toto zadání vrátí vždy hledané číslo 9,9999999999E+307

asi nemá být rozsah A:A a vracená hodnota ze sloupce 1


Toto vrátí jakoukoliv poslední číselnou hodnotu ve sloupci. Já bych chtěl i předposlední, předpředposlední až do 5-ti zpět.citovat
#043733
avatar
Jestli jsem pochopil dobře
=INDEX(A:A;POČET2(A:A)-0;1)
=INDEX(A:A;POČET2(A:A)-1;1)
=INDEX(A:A;POČET2(A:A)-2;1)
=INDEX(A:A;POČET2(A:A)-3;1)
=INDEX(A:A;POČET2(A:A)-4;1)
.. atdcitovat
#043734
Stalker
Řešení pomocí maticového vzorce, zadání se ukončí trojkombinací CTRL+SHIFT+ENTER. Rozsah je nastaven na A1:A100, vzorec ignoruje prázdné buňky. Konstantu k u funkce LARGE můžeš v případě potřeby napsat číslem místo funkce ŘÁDEK().
Příloha: xlsx43734_neprimy.odkazlarge.xlsx (9kB, staženo 4x)
citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse