< návrat zpět

MS Excel


Téma: funkce část textu 2. rss

Zaslal/a 3.9.2019 11:30

A pak ještě jedna věc. Mám v buňce C1 soubor jmen (pepa, franta, máňa..) oddelených čárkou.

Nyní budu vkládat do sloupce A vždy jméno a vedle toho ve sloupci B částku v Kč a potřebuji, aby když to jméno se bude nacházet v té buňce C1 (bude to jedno z těch jměn oddělených čárkou) tak aby se do stejného řádku ve sloupci C přesunula ta částka v Kč ze sloupce B.

Děkuji za pomoc

Zaslat odpověď >

#044125
avatar
Funkce NAJÍT nebo HLEDAT.citovat
#044130
elninoslov
=IF(ISERROR(FIND(UPPER(A2);UPPER($C$1)));"";B2)
=KDYŽ(JE.CHYBHODN(NAJÍT(VELKÁ(A2);VELKÁ($C$1)));"";B2)


Vylúči chybu pri zadaní malého písmena, ale aj tak odporúčam výberový zoznam (Overenie dát) pre zápis mena.

Môže nastať exotický problém, ak v C1 bude Alfredo a A bude Edo. Nájde ho, aj keď tam je Alfredo.

EIDT: SEARCH/HLEDAT ošetruje malé/veľké:
=IF(ISERROR(SEARCH(A2;$C$1));"";B2)
=KDYŽ(JE.CHYBHODN(HLEDAT(A2;$C$1));"";B2)
citovat
#044136
avatar

elninoslov napsal/a:

=IF(ISERROR(FIND(UPPER(A2);UPPER($C$1)));"";B2)
=KDYŽ(JE.CHYBHODN(NAJÍT(VELKÁ(A2);VELKÁ($C$1)));"";B2)

Vylúči chybu pri zadaní malého písmena, ale aj tak odporúčam výberový zoznam (Overenie dát) pre zápis mena.

Môže nastať exotický problém, ak v C1 bude Alfredo a A bude Edo. Nájde ho, aj keď tam je Alfredo.

EIDT: SEARCH/HLEDAT ošetruje malé/veľké:
=IF(ISERROR(SEARCH(A2;$C$1));"";B2)
=KDYŽ(JE.CHYBHODN(HLEDAT(A2;$C$1));"";B2)


Pokud budu mít mezi jmény čárku, tak možná by ten problém FREDO/ALFREDO šlo vyřešit tak, že bych to hledal s čárkami na konci a na začátku. Je to tak?citovat
#044137
avatar

bukva napsal/a:

Pokud budu mít mezi jmény čárku, tak možná by ten problém FREDO/ALFREDO šlo vyřešit tak, že bych to hledal s čárkami na konci a na začátku. Je to tak?

A prečo to nevyskúšaš sám? My nemáme tvoje dáta.citovat
#044138
elninoslov
Áno, v tom prípade by to mohlo byť takto nejako:
=IF(ISERROR(SEARCH(","&A2&",";","&$C$1&","));"";B2)
=KDYŽ(JE.CHYBHODN(HLEDAT(","&A2&",";","&$C$1&","));"";B2)

a malo by to obsiahnuť všetky mysliteľné eventuality čo ma napadajú.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Výpočet data narození

marjankaj • 20.1. 11:45

Výpočet data narození

Anonym • 20.1. 11:40

Výpočet data narození

marjankaj • 20.1. 11:00

Podbarvení buňky z jiného listu

Marekh • 20.1. 10:21

ActiveX - prvek ComboBox

OB • 20.1. 8:09

Výpočet data narození

JOHAN • 20.1. 6:30

ActiveX - prvek ComboBox

elninoslov • 20.1. 1:02