< návrat zpět

MS Excel


Téma: Odstranění indexu rss

Zaslal/a 21.2.2020 8:31

Zdravím Vás,

potřeboval bych pomoci. V práci řeším zdlouhavě porovnání sloupců.

Potřeboval bych jednoduché makro, nebo nějakou lepší fuknci.

Máme v práci výkresy, které se skládají z deseti až dvanácti znaků.

První tři jsou obvykle písmena poté 7-9 znaků čísla. Poté se rozdělují výkresy dle změn (indexů) na A až Z takže reálné číslo vypadá například takto

ABC022214587B

Chtěl bych nějakou funkci, která mě z celého výkresového čísla, pokud obsahuje indexaci na konci (v tomto případě písmeno "B") do nového sloupce přepsal pouze ABC022214587.

Děkuji za pomoc

Zaslat odpověď >

Strana:  1 2   další »
#045983
avatar
třeba takto?
=KDYŽ(JE.ČISLO(IFERROR(ZPRAVA(A1;1)*1;ZPRAVA(A1;1)))=PRAVDA;A1;ČÁST(A1;1;(DÉLKA(A1))-1))citovat
#045984
avatar
... nebo ?
=KDYŽ(JE.CHYBA(HODNOTA(ČÁST(A1;DÉLKA(A1);1)));ČÁST(A1;1;DÉLKA(A1)-1);A1)
=IF(ISERR(VALUE(MID(A1,LEN(A1),1))),MID(A1,1,LEN(A1)-1),A1)citovat
#045985
avatar

Barth napsal/a:

... nebo ?
=KDYŽ(JE.CHYBA(HODNOTA(ČÁST(A1;DÉLKA(A1);1)));ČÁST(A1;1;DÉLKA(A1)-1);A1)

mnohem jednoduší 9citovat
#045986
elninoslov
Ešte o mikrokúštik kratšie :)
=LEFT(A1;LEN(A1)-IFERROR(RIGHT(A1)*0;1))
=ZLEVA(A1;DÉLKA(A1)-IFERROR(ZPRAVA(A1)*0;1))
citovat
#045989
avatar
Super díky moc

A ještě jeden dotaz, šlo by vymyslet něco, co by na základě stejného pravidla zvýraznit následující:

V přiloženém souboru jsou dva sloupce A a B, pojmenované Global code a PCL.

CHtěl bych asi pomocí makra na tlačítko, zvýraznit (zeleně) ve sloupci PCL ty položky, které se shodují s položkami se sloupce A, a nebo mají stejný základ (bez posledního písmene indexu).

Červeně zvýraznit ze sloupce PCL ty položky, které se nenacházejí ve sloupci A

Díky moc
Příloha: xlsx45989_porovnani-bomu.xlsx (24kB, staženo 6x)
citovat
#045990
avatar
Ještě zajímavější by bylo zjistit číslo uprostřed, vpředu obvykle tři písmena nebo dvě či čtyři, vzadu jedno...citovat
#045993
elninoslov
milos85 : COUNTIF() s parametrom čo sme teraz získali &"?" prípadne &"*"

Barth : Kedysi som robil vzorce na vyťahovanie čísel z akýchkoľvek reťazcov, nemôžem to nájsť. Uveďte príklad, možno poriešime ...citovat
#045994
avatar

elninoslov napsal/a:

milos85 : COUNTIF() s parametrom čo sme teraz získali &"?" prípadne &"*"

Barth : Kedysi som robil vzorce na vyťahovanie čísel z akýchkoľvek reťazcov, nemôžem to nájsť. Uveďte príklad, možno poriešime ...


Vůbec netuším elninoslov jaká má být syntaxe. Hodil jsem tam excel, tak kdyby se Vám chtělo něco vytvořit, byl bych vděčný. Díkycitovat
#045998
avatar
milos85: Rád bych pomohl a hrál si, ale není čas.
Nápověda je, že na sčítání počtu výskytů máš použít funkci COUNTIF a zadat jako hledané získaný text resp. buňku se získaným textem. "*" a "?" jsou zástupné znaky, * pro více znaků a ? pro jeden libovolný znak, více se dozvíte v nápovědě pro Like, čímž lze porovnávat masku. Znak & sloučí text obdobně jako funkce CONCATENATE. Nejdřív si to třeba zkus v pokusném sloupci a pak lze zadat do podmíněného formátování jako vzorec pro to barvičkaření. Logiku znáš vlastně nejlíp, jak to má fungovat. Snad to pomůže...

elninoslov: Díky za nabídku, není to akutní, to byl jen příspěvek tzv. mimo mísu. Snad příště a díky za pomoc minule.citovat
#046024
avatar
milos85: Dal jste to?citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

PowerPivot - kalendář a 30min časy

Vikous • 3.4. 21:20

PowerPivot - kalendář a 30min časy

Vikous • 3.4. 21:04

Desetinné číslo v InputBox

elninoslov • 3.4. 20:18

Načtení buňky při otevření dokumentu

marjankaj • 3.4. 19:34

PowerPivot - kalendář a 30min časy

mepexg • 3.4. 17:14

Načtení buňky při otevření dokumentu

Roman-M • 3.4. 16:54

PowerPivot - kalendář a 30min časy

eLCHa • 3.4. 16:02