< návrat zpět

MS Excel


Téma: VYHLEDAT rss

Zaslal/a 19.4.2020 8:51

Ahoj,

můžete mi prosím někdo zjistit proč mi nefunguje příkaz VYHLEDAT? Najde mi to pouze jednu položku a pak už to jenom vypíše "není k dispozici". U příkazu POZVYHLEDAT mi to, ale všechny čísla, která jsou obsažena v druhém sloupci najde. Potřebuji jenom zjistit výskyt.
Děkuji

Příloha: xlsx46456_test2.xlsx (19kB, staženo 14x)
Zaslat odpověď >

#046457
mepexg
Príloha
Příloha: xlsx46457_46456_test2.xlsx (19kB, staženo 12x)
citovat
#046458
elninoslov
Ja myslím, že Vám tam chýba ešte aj posledný parameter:
=IFERROR(IF(MATCH(C3;$F$3:$F$134;FALSE)>0;"ANO");"není k dispozici")
=IFERROR(KDYŽ(POZVYHLEDAT(C3;$F$3:$F$134;NEPRAVDA)>0;"ANO");"není k dispozici")

prípadne môžete použiť aj
=IF(COUNTIF($F$3:$F$134;C3)=0;"není k dispozici";"ANO")
=KDYŽ(COUNTIF($F$3:$F$134;C3)=0;"není k dispozici";"ANO")
citovat
#046459
avatar
Nejdříve bych si na tvém místě zjistil, co má vůbec funkce VYHLEDAT dělat.

Dle popisu funkce VYHLEDAT: Výsledek (ve tvém případě tam máš jen výraz "ANO") má být oblast obsahující pouze jeden řádek nebo sloupec + velikost oblasti je stejná jako velikost oblasti argumentu "Hledat" (ve tvém případě oblast $F$3:$F$134). Toto tedy tvůj zápis nesplňuje.

Navíc je tato funkce udělaná tak, že pokud nenajde přesnou shodu argumentu v dané oblasti, tak vrátí největší z menších hodnot. Jinými slovy pro řešení tvého problému to není úplně vhodná funkce. I když taky by to s ní teoreticky přes podmínku ve funkci KDYŽ šlo.
=IFERROR(KDYŽ(C3=VYHLEDAT(C3;$F$3:$F$359); "ANO"; ""); "")Nicméně funkce VYHLEDAT je již zastaralá a je v nabídce jenom z důvodu zpětné kompatibility předchozích verzí Excelu. Když už bys to chtěl řešit přes vyhledávací funkci, tak použij radši třeba SVYHLEDAT v kombinaci s funkcí JE.NEDEF.
=KDYŽ(JE.NEDEF(SVYHLEDAT(C3; $F$3:$F$359; 1; NEPRAVDA)); ""; "ANO")Já osobně bych to řešil přes funkci KDYŽ a COUNTIFS.=KDYŽ(COUNTIFS($F$3:$F$359; C3)>0; "ANO"; "")P.citovat
#046460
avatar
že by pre toto?
Příloha: png46460_lookup.png (46kB, staženo 24x)
46460_lookup.png
citovat
#046462
avatar
osobně bych to řešil:
=VYHLEDAT(C3;$F$3:$F$134;$F$3:$F$359)=C3

případně
=IFNA(VYHLEDAT(C3;$F$3:$F$134;$F$3:$F$359)=C3;NEPRAVDA)

Vysvětlení: Testujeme, jestli funkce našla to, co měla najít.

Vyhladat potřebuje setříděnou oblast hledání. Proti countif, případně hledání na přesnou shodu je pak u většího objemu dat řádově rychlejší.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

Zaloha zošitov okrem hdd a nas

milada • 23.9. 22:03

VLOOKUP jen pro poslední přidané řádky

Jiří497 • 23.9. 21:59

Zaloha zošitov okrem hdd a nas

lugr • 23.9. 21:47

Zaloha zošitov okrem hdd a nas

Milada • 23.9. 21:28

zlucenie buniek do jedneho

pavol14pavol • 23.9. 21:11

zlucenie buniek do jedneho

robert13 • 23.9. 19:23

vyzisti pocet dni s datumu

robo • 23.9. 19:01