< návrat zpět

MS Excel


Téma: Vyhledávání s VBA v databázi rss

Zaslal/a 15.7.2020 17:06

Zdravím,
mohl by jste mi někdo poradit?
Range("A4").FormulaLocal = "=SVYHLEDAT(A2;Database!B:L;SLOUPEC(A);0)"
je to ale špatně napsané...


,ale potřeboval bych když najde hodnotu v v buňkách B:L
tak to napíše hodnotu, která se nachází v daném řádku ve sloupci A.

Př.
A B C D
5 20 21 22
6 50 52 54
7 81 82 83
10 10 5 20

budu hledat např. 82 a vypíše mi to číslo 7 ze sloupce A

Zaslat odpověď >

#047328
avatar
Ještě přidávám soubor..
mám v Range A2 769 a v Range A4 mi to najde 766
i když tam je :
Range("A4").FormulaLocal = "=SVYHLEDAT(A2;Database!A:L;SLOUPEC(A))"

a na daném řádku ( v sheets Database ), když to vyhledá 769 se nachází 828 ( ve sloupci A ) ale napíše to tam 766 což vůbec nechápu..
Příloha: zip47328_kardex-v2.2.xlsm.zip (100kB, staženo 4x)
citovat
#047329
avatar
Asi jste nepochopil tuto funkci.
Funkce SVYHLEDAT vyhledá v prvním sloupci tabulky zadanou hodnotu a vrátí hodnotu buňky ve stejném řádku jiného sloupce dané tabulky.

Ten jiný sloupec je napravo. Takže vyhledá hodnotu ve sloupci jedna a vrací hodnotu ze stejného řádku ve sloupci 2 nebo 3 nebo 4...citovat
#047330
avatar
Načo sú mu funkcie?
Vo VBA to urobí dvoma vnorenými cyklami.citovat
#047331
avatar

Jiří497 napsal/a:

Asi jste nepochopil tuto funkci.
Funkce SVYHLEDAT vyhledá v prvním sloupci tabulky zadanou hodnotu a vrátí hodnotu buňky ve stejném řádku jiného sloupce dané tabulky.

Ten jiný sloupec je napravo. Takže vyhledá hodnotu ve sloupci jedna a vrací hodnotu ze stejného řádku ve sloupci 2 nebo 3 nebo 4...

Ja jsem ÍÁ, a jakou funkci mám zadat ať to hledá v lokaci B:L akdyž najde tak to napíše řadek A ?citovat
#047332
avatar
https://office.lasakovi.com/excel/funkce/index-pozvyhledat-vyber-unikatnich-dat/

zhruba v polovině: Jak nahradit SVYHLEDAT

nebo jak píše marjankaj pomocí vnořených cyklů.
Ja bych asi použil FIND ve VBA.citovat
#047333
avatar

Jiří497 napsal/a:

https://office.lasakovi.com/excel/funkce/index-pozvyhledat-vyber-unikatnich-dat/

zhruba v polovině: Jak nahradit SVYHLEDAT

nebo jak píše marjankaj pomocí vnořených cyklů.
Ja bych asi použil FIND ve VBA.

Ale tam určím primárně vyhledávací jiný sloupec, ale když tam je vyhledavacich sloupců víc tak mi to nejde..

Ale vic se mi líbí ten Váš nápad find to bude asi lepší. Nemáte někdo nějakou ukázku kódu?

Děkujicitovat
#047335
avatar
http://wall.cz/index.php?m=topic&id=46813#post-46814citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

VBA vyhledat a zapsat

Stalker • 27.9. 23:02

VBA vyhledat a zapsat

Fantasyk • 27.9. 22:15

VBA vyhledat a zapsat

Stalker • 27.9. 22:04

VBA vyhledat a zapsat

Fantasyk • 27.9. 21:03

vyhledávání s maticí

Fantasyk • 26.9. 11:35

Automatické doplnění

marjankaj • 25.9. 14:27

Automatické doplnění

Dingo • 25.9. 14:25