< návrat zpět

MS Excel


Téma: Rozdělení služeb rss

Zaslal/a 12.10.2020 11:06

Ahoj,

potřeboval bych poradit s pro mne neřešitelným úkolem. Jako přílohu dávám automatický kalendář, který bych chtěl vyplnit automaticky službami zaměstnanců. Pokud se v buňce AG6 změní rok tak se kalendář přepočte a červeně se označí svátky dle listu Svátky. Potřeboval byl pod každým datem osadit řádky odpolední, sobotní, rozvoz a díly jmény ze seznamu na listu Jména. Bohužel se do toho musí zakomponovat několik podmínek.

https://uloz.to/file/Svolq4PR7cAu/rocni-kalnedar-xlsx

A to :

1)Každý pracovní den (mimo svátky) bude mít odpolední jeden člověk ze seznamu odpolední na listu Jména.

2)Každý týden (pouze pracovní dny) bude mít rozvoz jeden člověk ze seznamu rozvoz na listu jména v kuse a to celý pracovní týden mimo svátky. Po týdnu se střídají.

3)Sobotní (pouze soboty) bude mít vždy jeden člověk ze seznamu sobotní na listu Jména. Každou sobotu někdo jiný a to vždy mimo dny 24.12., 25.12., 26.12., 1.1. a 31.12.

4)Díly má vždy celý víkend (pouze soboty a neděle) jeden člověk ze seznamu díly na listu Jména.

5)Kdo má v pátek odpolední, aby neměl sobotní.

6)Kdo má rozvoz, aby neměl odpolední.

7)Když se do nějakého seznamu přidá zaměstnanec, aby se přepsalo automaticky rozdělení služeb.

8)Když se z nějakého seznamu odebere zaměstnanec, aby se přepsalo automaticky rozdělení služeb.

9) při změně roku se to přeplánuje ale v návaznosti na předchozí rok (kdo končil na konci roku ze službou, aby hned nezačínal a neměl tak 0 po sobě.)

Snad je to srozumitelné a hlvně doufám, že je to v Excelu Možné.

Zaslat odpověď >

Strana:  1 2 3 4 5   další »
#048371
lugr
Tahle už je pro mě asi vyšší dívčí a ani na to nemám čas, ale když už bych se na to měl podívat, tak co znamená jeden ze seznamu? Má to nějaký systém jak se zaměstnanci střídají nebo náhodně? To je první věc, které nerozumím. 4citovat
#048372
avatar
Klidně popořadě a zároveň respektovat podmínky.citovat
#048373
avatar
Nevím, jestli do toho někdo půjde, ale pokud bych se měl rozhodovat sám za sebe, tak něž bych začal, tak bych chtěl vidět vzorový příklad pro alespoň první dva měsíce.citovat
#048374
avatar
A co se stane, když si někdo vezme dovolenou nebo bude mít nemocenskou, OČRcitovat
#048375
lugr
No já nad tím po chvilkách přemýšlím a taky si myslím, že stačí když Vám do toho jeden zaměstnanec hodí vidle a celý plán je v ....citovat
#048376
avatar
Taky bude potřeba stanovit priority, když nastane souběh neslučitelných směn.
Zaměstnanec A má mít v pá odpoledni a vychází mu i so. Co má přednost sobota nebo pátek?
Co když mu vychází v pá odpolední, rozvoz a sobotní nebo víkendová šichta.
Když někoho přeskočím, dát mu nejbližší šichtu nebo jej zařadit na konec kolečka?
A klidně můžeme pokračovat dál...citovat
#048377
lugr
Už mám asi hotový řádek odpolední.

=KDYŽ(NEBO(DENTÝDNE(B6;11)=6;DENTÝDNE(B6;11)=7;JE.NEDEF(SVYHLEDAT(B6;Svátky!$C$5:$C$17;1;0))=NEPRAVDA);"";SVYHLEDAT(WEEKNUM(B6;11);Jména!$B$3:$C$55;2;NEPRAVDA))

s tím, že na listu Jména si musí pán nastavit na každý týden jméno.

A touhle jednoduchou cestou bych šel všechny řádky.citovat
#048378
avatar

lugr[code napsal/a:

=KDYŽ(NEBO(DENTÝDNE(B6;11)=6;DENTÝDNE(B6;11)=7;JE.NEDEF(SVYHLEDAT(B6;Svátky!$C$5:$C$17;1;0))=NEPRAVDA);"";SVYHLEDAT(WEEKNUM(B6;11);Jména!$B$3:$C$55;2;NEPRAVDA))[/code]
chybička se vloudila místo Jména!$B$3:$C$55 má být Jména!$A$3:$B$55.

Jinak jsme se dostali k prvnímu nejasně definovanému zadání. Já to pochopil, že se na odpolední střídá každý den někdo jiný.citovat
#048382
avatar
Já bych to viděl na makro.
Pokud vzorečky, tak snad jen matice. Je to značně provázané a spousty podmínek.
Uděláš první řádek a jak ho navážeš na zbytek?citovat
#048383
lugr
Já bych to neviděl tak dramaticky.

Hodil jsem pár podmínek a rozložení lidí ať už si vyřeší pán na listu Jména

Makro nedám.
Příloha: xlsx48383_rocni-kalendar.xlsx (42kB, staženo 6x)
citovat

Strana:  1 2 3 4 5   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

ZOSKUPENIE ÚDAJOV

Daniel_11 • 29.10. 10:10

kopie mezi instancemi Excelu

rinma • 29.10. 9:44

kopie mezi instancemi Excelu

Stalker • 29.10. 8:44

kopie mezi instancemi Excelu

rinma • 28.10. 19:01

kopie mezi instancemi Excelu

rinma • 28.10. 18:58

den hodina minuta sekunda v jednej bunke

lugr • 28.10. 12:50

Kombinace url odkazů

Petan111 • 28.10. 11:46