< návrat zpět

MS Excel


Téma: rozdělení čísla do více buněk dle násobku rss

Zaslal/a 2.12.2020 14:51

Dobrý den všem, chtěl bych Vás poprosit, jestli mi může někdo poradit jestli jde, popř. jak, rozdělit číslo podle určitého násobku.
Příklad: potřebuji rozdělit 18h do 3 dnů (po 8h denně plus zbytek)(viz přiložený soubor). Děkuji rady. Pavel

Příloha: xlsx49111_tabulka.xlsx (12kB, staženo 17x)
Zaslat odpověď >

#049117
avatar
např. do R2:
=KDYŽ(A(Y$1>=$B2;Y$1<=$C2);MIN($E2-8*(Y$1-$B2);8);"")citovat
#049122
avatar

lubo napsal/a:

např. do R2:=KDYŽ(A(Y$1>=$B2;Y$1<=$C2);MIN($E2-8*(Y$1-$B2);8);"")
drobná chybička se vloudila. Pokud se vzorec vloží do R2, tak ve vzorci místo "Y" musí být "R":
=KDYŽ(A(R$1>=$B2;R$1<=$C2);MIN($E2-8*(R$1-$B2);8);"")A samozřejmě pak rozkopírovat do celé tabulky R2:V11.
Jinak pěkná práce.citovat
icon #049123
eLCHa
Do buňky F2 vložte=ZVOLIT(A(F$1>=$B2;F$1<=$C2)+(F$1=$C2)+1;0;8;MOD($E2;8)) případně pokud nechcete 0=ZVOLIT(A(F$1>=$B2;F$1<=$C2)+(F$1=$C2)+1;"";8;MOD($E2;8)) a rozkopírujtecitovat
#049190
avatar
Děkuji všem za pomoc, za se moje vědomosti o něco posunuly. Ale jestě jednu maličkost bych měl, jsetli to půjde vyřešit.
Tabulka v příloze s popisem co to dělá.
Díky
Příloha: xlsx49190_49111_update.xlsx (14kB, staženo 4x)
citovat
#049211
avatar

eLCHa napsal/a:

Do buňky F2 vložte=ZVOLIT(A(F$1>=$B2;F$1<=$C2)+(F$1=$C2)+1;0;8;MOD($E2;8)) případně pokud nechcete 0=ZVOLIT(A(F$1>=$B2;F$1<=$C2)+(F$1=$C2)+1;"";8;MOD($E2;8)) a rozkopírujte


eLCHa poradis prosim jeste jak to upravit nebo zmenit, kdyz mam 3 dny a 24 hodin, tak mi to do dvou dnu napise 8 a do tretiho 0 misto 8
dikycitovat
#049213
avatar
doplňte si tam třeba podmínku
vzorec jsem zkoušel ve spodnější tabulce vašeho posledně uploadovaného soubrou tzn.: vložit do F17 a rozkopírovat

=KDYŽ(ZVOLIT(A(L$16>=$B26;L$16<=$C26)+(L$16=$C26)+1;"";8;MOD($E26;8))=0;"";ZVOLIT(A(L$16>=$B26;L$16<=$C26)+(L$16=$C26)+1;"";8;MOD($E26;8)))citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura III

Oblíbený formulář Faktura byl vylepšen a rozšířen. Formulář faktura III
Více se dočtete zde.

Aktivní diskuse

excel se mi pokakal nefunguje funkce roztažení

lugr • 24.1. 8:21

excel se mi pokakal nefunguje funkce roztažení

Fantasyk • 23.1. 21:57

hromadne doplnenie ciarky

marjankaj • 22.1. 20:11

hromadne doplnenie ciarky

michalko • 22.1. 19:49

Tabulka dovolených 2021

lugr • 22.1. 17:59

Tabulka dovolených 2021

00001 • 22.1. 15:38

řazení dat - Makro nereaguje změnu v daném listu

elninoslov • 22.1. 13:15