Příspěvky uživatele


< návrat zpět

Strana:  1 2   další »

Mám sice CZ Excel, ale první varianta funguje 1
Druhá ne.
Geniální, díky moc! 1

Díky všem, vzorec od Elninoslov funguje! 1

Ale narazil jsem na další potíž, když jsem chtěl ošetřit chybovou hlášku.

Mám teď vzorec ve tvaru: Range("A" & x).FormulaLocal = "=IFERROR(VLOOKUP(H" & x & ";Zákazníci!$A$2:$C$1000;2;FALSE);"")", tedy aby v případě chyby nezobrazoval nic, ale opět mi to hlásí Run-time error '1004' Aplication-defined or object-defined error. A to i když nahradím středníky čárkami...
Přitom když stejný vzorec zkopíruju do buňky manuálně (pouze nahradím proměnnou konkrétní hodnotou), tak je vše v pořádku...

Díky za ochotu

Má prosím někdo zkušenost s tímto pozoruhodným úkazem, že vzorec napsaný v makru s čárkami se do tabulky zapíše správně se středníky, ale nefunguje, a fungovat začne až poté, co se nezměněný jen odentruje?

Díky

Teď jsem to vyzkoušel, díky. V makru mám tedy ve vzorci čárky, vzorec se tentokrát zapíše (úspěch!) a čárky se v tabulce automaticky změní na středníky. Takže vzorec je již v buňce zapsaný správně, nicméně vrací mi #NÁZEV? Ale když dám kurzor do editovacího řádku a jen stisknu ENTER, vzorec najednou začne fungovat (!), i když zůstal úplně stejný... Co s tím? Potřeboval bych, aby fungoval hned, bez toho enteru... 1

Pardon, nevkládám do sloupce H, pouze z něj beru první hodnotu do vzorce...

Prosím poraďte:

Potřebuji do buněk ve sloupci H vložit pomocí makra vzorec =SVYHLEDAT() s proměnnou "x", kde proměnná "x" obsahuje číslo řádku.

Zkusil jsem tento výraz: "=SVYHLEDAT(H" & x & ";Zákazníci!$A$2:$C$1000;2;NEPRAVDA)", ale nefunguje to.

Nefunguje mi dokonce ani verze bez proměnné, třeba: "=SVYHLEDAT(H30;Zákazníci!$A$2:$C$1000;2;NEPRAVDA)".

Napíše mi to "Run-time error '1004' Aplication-defined or object-defined error

Přitom když do těch úvozovek uzavřu jiný vzorec(třeba "=ROW()"), zapíše se do buněk bez problémů.

Kde je chyba?

Předem moc dík za radu.

Stalkere, moc díky, to je výborné a jednoduché řešení 1

Tak ještě jednou prosím, věděl by někdo, jak vytisknout jen část formuláře, případně jen rámeček (frame) na něm? Pokud na to žádná funkce či vzorec neexistuje, prosím o sdělení, abych nehledal zbytečně. Díky.

Zdravím a prosím o radu: mám formulář a na něm rámeček (frame) s daty. Je možné nějakým příkazem zajistit, aby se mi z formuláře vytiskl jen ten rámeček s daty a vše co je okolo (např. tlačítka) nikoliv? Případně bych potřeboval nějaký příkaz, kterým bych na formuláři mohl vymezit určitou oblast tisku podobně, jako se to dá udělat v sešitu. Předem moc děkuji za radu.

Jak je to jednoduchý, když to někdo umí 1 Funguje, díky!

Díky za všechno. Mám ještě doplňující otázku: jakou funkcí VBA lze zjistit pořadí listu v sešitu podle jména listu? Díky.

To je přesně ono, funguje to skvěle! Díky moc!

Pořád to samé, při otevření hlásí nečitelný obsah. Nechápu, v čem je problém, stahoval jsem si odsud už několik řešení. Můžeš to prosím uložit pod nějakou starší verzí Excelu?

Díky, ale nejde mi to otevřít, hlásí mi to nečitelný obsah. Mám Excel 2007. Můžeš to poslat ještě jednou?

Tak bohužel, nemám dost zkušeností na to, abych to dokázal přepracovat ke svému účelu. Takže opakuji svou prosbu, mohl by prosím někdo propojit tabulku s formulářem tak, aby se ve formuláři dalo listovat mezi jednotlivými záznamy, editovat je a mazat? V příloze je tabulka s jednoduchým formulářem. Další pole a funkce už pak snad budu schopen dotvořit. Díky za pomoc.


Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Ověření datumu TextBox1.Text

elninoslov • 18.10. 20:15

Auto mazanie emailov

elninoslov • 18.10. 20:01

Ověření datumu TextBox1.Text

Scraper • 18.10. 18:25

Auto mazanie emailov

Pavol1 • 18.10. 17:10

zdroj dat ve VBA

elninoslov • 18.10. 17:08

zdroj dat ve VBA

lubo • 18.10. 15:40

EXCEL VBA vyhledání buňky

lubo • 18.10. 15:39