Příspěvky uživatele


< návrat zpět

Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 12

Zdar Lubo,

skvělý, tak to je přesně ono. Taky jsem to zkoušel dřív, akorát v bodě 6 jsem nevybral den, ale Přínos, což byla hovadina a hodilo to #N/A
A trefil ses dobře, je to Running Total In.

Sláva a díky moc 5

Lubo promiň, ale nějak se na Tvou nápovědu nechytám. Ještě k tomu mám us verzi excelu. Mohl bys, pls, zkusit ještě jednou? Dík

Beru zpět, na ten váš vzoreček je náhoda krátká. Je to dost dobré řešení. 1
Předběžný výzkum jinde zatím potvrzuje, že tyto úlohy KT pravděpodobně nemá ve svém repertoáru.

Dík za odpověď, i když mně moc nepotěšila. Z názvu KT jsem dedukoval, že kontingent je přírůstek, tedy že "přírůstková" úloha je v možnostech KT. No nic, zkusím ještě popátrat, jestli je to doopravdy mimo možnosti KT.
K tomu důmyslnému vzorci použitému ve všem řešení ve sloupci "kumulace období": pořád nevylučuje možnost chyby, neboť porovnává výsledky dvou Countifů a ty by se mohly někdy shodnout kromě požadovaných průniků i čirou náhodou. Ale i tak velké uznání, s největší pravděpodobností to použiju.

Ještě jsem zapomněl dodat, abych nebyl za lenocha, při prohledávání tohoto fóra jsem narazil na prakticky identický problém http://wall.cz/index.php?m=topic&id=15102.
Úspěšné řešení bylo na tomto linku http://excelplus.net/forum/viewthread.php?thread_id=848&pid=3676#post_3676, který mi hází "stránka nenalezena"

Ahoj,
potřeboval bych vytvořit graf z jednotlivých hodnot, kde by se jednotlivé denní přírůstky kumulovaly. V přiloženém hypotetickém příkladě jsem si pomohl sloupcem, kde sečítám předchozí přírůstky.
Ale má to několik háčků: pokud je několik záznamů ve stejném dni, potřebuju je mít v grafu sečteny pro daný den.
Zkoušel jsem to konti tabulkou, ale tím pádem se kumulovaný zisk přičte opakovaně. Ve finále mi KT hlásí kumulovaný zisk 4182, což je špatně, má to být 2219
Navíc pokud bych chtěl v té KT filtrovat např. za jednotlivé osoby, tak taky dostávám špatné výsledky.
Čili všechno zlo tam vnáší ten pomocný kalkulovaný sloupec "kum. zisk"
Mám tušení, že KT graf si s tímto dovede poradit bez pomocného sloupce, ale zaboha na to nemůžu přijít.
Dík moc, M

zkus prohlednout toto vlakno, treba najdes dalsi inspiraci
http://wall.cz/index.php?m=topic&id=9735&page=1#posts

Pouzij rozhodovaci funkci KDYZ
napr takhle:
=KDYŽ(C3-B3<0;0;C3-B3) - v pripade zaporneho vysledku zobrazi nulu
anebo
=KDYŽ(C3-B3<0;"";C3-B3) v pripade zaporneho vysledku zobrazi nic

Neco jsem googlil a zda se, ze je potreba vytvorit ten Informační soubor pracovní skupiny (workgroup information file). Ten vytvoris v accessu podobne jak password, tedy Tools - Security - Workgroup administrator.

Akorat jenom toto nestaci, je potreba tu cestu k tomuto souboru nejak zaintegrovat do connection stringu.
Tady se o tom neco mluvi, ale moc se nechytam:
http://social.msdn.microsoft.com/Forums/en-US/Vsexpressvb/thread/3b0bd93e-65a5-475d-bbdf-0419b4a18e4e/

Pokud se Ti podari pokrocit, dej vedet jak na to.
Dik,
Milan

Ahoj,

mam dojem, ze sis spletl dva podobne prvky.
To, co mas vlozene v bunce B4 je ComboBox.
To, co popisujes je overeni dat, ktere se ovlada pres ribbon Data - Overeni Dat (Data Validation).

Myslim, ze to Overeni dat je dostatecne intuitivni, abys tomu vdechl zivot dle svych predstav

Díky hoši oběma.
Ne že bych se s funkcí GETPIVOTDATA nesetkal, ale netušil jsem, že je tak inteligentní.
Vůbec by to chtělo důkladnější znalosti KT. Nedávno jsem programoval kód na elegantnější ovládání stránkových filtrů KT a dost jsem se u toho natrápil, než jsem to spytlíkoval. Potom přišel kolega s tím, že takový nástroj už v excelu je a aktivuje se ikonou z nástrojů KT "Insert Slicer" (hned vedle ikony "Sort"). Zajímal by mě český název této vychytávky.
Dík, Milan

Jo, vlastně máš pravdu. Já jsem tím Grand Totalem myslel tu buňku (Value), kde se protíná Grand Total za řádky a Grand totalem za sloupce. A ta mění obě souřadnice.

Takže ještě by se to muselo prohledávat vodorovně, pak by to fungovalo. A asi by to kvůli univerzálnosti ještě chtělo dotázat KT na název Grand Total, což, jak jsem zjistil taková vlastnost KT je, v mé anglické verzi vrací zase "Grand Total", ale v české by to asi bylo jinak 5

Díky AL.
Tak to je smutná správa.
Ten Grand total není furt ve stejném sloupci, takže POZVYHLEDAT se taky komplikuje. Ale na něco jsem přišel:

Když se u zvolené KT dotazuju na .TableRange1.Address, tak mi to vrátí např. $B$11:$C$15, přičemž ten Grand Total je v buňce C15. Z toho už jsem schopen to vypreparovat.
Ale přesto dík za nakopnutí 1

Ahoj, mám KT se stránkovým filtrem. Když není nasazený žádný stránkový filtr, tak KT má nějaký počet řádků a nějaký počet sloupců. Když něco zafiltruju, tak se velikost té KT zmenší, čili skryje řádky a sloupce, ve kterých pro daný stránkový filtr není žádná nenulová hodnota.
Takže dotaz zní: dá se nějak nastavit, aby se KT zobrazovala pokaždé ve stejné velikosti, tak aby total za řádky a sloupce byl vždy ve stejné buňce? Mám excel 2010 US verze.
Pokud ne, je nějaká finta, jak se pomocí VBA dopídit ve které buňce se ten Grand Total nachází?
Dík, Milan

Nemyslim si, ze by Solver (Resitel?) souvisel s VBA referencemi.
kdyz se v mem excelu2010 mrknu do Options, Add-Ins, tak u Solveru vidim nasledujici umisteni:
C:\Program Files\Microsoft Office\Office14\Library\SOLVER\SOLVER.XLAM

Mrkni, jestli to mas taky tam


Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 12

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

špatný výpočet ze zisku - příčina?

Jakoby • 12.7. 12:35

Řazení podle času v kategoriích

Marekh • 12.7. 9:55

Porovnávací Tabulka

Jess • 8.7. 20:49

Vzorec pro zkopírování obsahu buňky.

veny • 6.7. 8:28

Vzorec pro zkopírování obsahu buňky.

Tonda_Hu • 5.7. 21:17

Porovnávací Tabulka

Jess • 5.7. 13:49

Kontexove menu na tlačenie tabuliek

ivana12 • 3.7. 14:35