Příspěvky uživatele


< návrat zpět

Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 63

Neznám přesné využití, nicméně nejjednodušší řešení je přes pomocný sloupeček a funkci KDYŽ.
P.

Nechce se mi jít úplně do detailu, máte v tom totiž docela zmatek ;-). Každopádně, když chcete uložit do proměnné výsledek běžné funkce, která je zabudovaná v MS Excel, tak se k tomu využívá příkaz "Application.WorksheetFunction". Tedy žádné uvozovky, rovnítko a české názvy funkcí...
P.

Např.:
Promenna = Application.WorksheetFunction.Sum(Range("A1:A10"))

Principiálně asi hledáte příkazy "ActiveWorkbook.Name" a "ActiveSheet.Name".
P.

Např.:
Range("A1").Value = ActiveWorkbook.Name
Range("A2").Value = ActiveSheet.Name

Ano, určitě lze daný problém vyřešit makrem. Ukázku pro jeden posuvník posílám v příloze.
P.

Ukázka řešení přes makra:

Tento problém lze vyřešit např. přidáním pomocného sloupce se vzorcem.
P.

Ukázka pro sloupec "G" a buňku G2
(následně roztáhnout vzorec pro celý sloupec):

=KDYŽ(A2<>""; A2; G1)

Zkuste využít funkcionality Excelu pro import XML. Karta Data / Z jiných zdrojů / Z importu dat XML.
P.

Principiálně není nutné toto řešit přes makro, postačí obyčejné podmíněné formátování pomocí vzorce (Domů / Podmíněné formátování / Nové pravidlo).
P.

Např.:
=IFERROR((NAJÍT("_"; B1; 1)-1) > 30; DÉLKA(B1) > 30)

Podle ukázkového vzorku dat by mělo jít vyřešit přes funkci SUMIFS.
P.

Řešením je funkce SUMIFS.
P.

Principiálně to můžete udělat přes "skládání" grafů, tedy vložit si novou řadu v podobě sloupcového grafu, který bude splňovat požadované zadání.
P.

Je to ta správná funkce ;-).
P.

Např.:
=COUNTIFS(DATA!F:F; A2; DATA!Q:Q; ">" & 100%)

Přesnou příčinu jsem nezkoumal, ale evidentně ti Excel v určitých momentech nebral zadaný inkrement jako jedno číslo (25), ale jako číslo 2 plus znak 5 (proto 1+2 & 5 = 35; 2+2 & 5 = 45 apod.). Při testování jsem se s tím taktéž setkal.

Preventivní opatření/řešení je jednoduché, definuj si v kódu daný inkrement jako konstantu.

Každopádně, pokud se jedná o jednorázové řešení, tak pro definování záhlaví není potřeba znalost VBA, vše lze nastavit přímo v Excelu = karta Rozložení stránky / Tisk názvů / Záhlaví a zápatí / Vlastní záhlaví...

P.

Ukázka kódu s konstantou:
Sub Zahlavi()
Const inkrement As Byte = 25
With Sheets("List2").PageSetup
.RightHeader = "&""Arial""&6strana &P+" & inkrement
.LeftHeader = "&""Arial""&6strana &P"
End With
End Sub

@Janinka88: Vzhledem k tomu co píšete, a za předpokladu, že ve sloupci "A" nebude nikdy nic navíc, co nechcete sčítat, a za předpokladu, že se nebudou odstraňovat první 3 řádky, tak stačí prosté (ve verzi Excelu "xlsx"):
=SUMA(A4:$A$1048576)Díky absolutnímu adresování (přes $) úplně poslední buňky listu se ani při přidávání/odstraňování řádků 4 až 1048576 v součtovém vzorečku nic nemění...

P.

Jednou z možností je využití odkazování na oblast přes funkce NEPŘÍMÝ.ODKAZ a ODKAZ.
P.

Například:
=SUMA(NEPŘÍMÝ.ODKAZ(ODKAZ(4;1;4) & ":" & ODKAZ(10000;1;4); PRAVDA))

Řešením je funkce INDEX a POZVYHLEDAT.

P.


Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 63

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Čas od do

jarek1111 • 18.4. 13:46

Čas od do

lubo • 18.4. 11:13

Čas od do

jarek1111 • 18.4. 8:32

Čas od do

jarek1111 • 18.4. 8:31

Makro smyčka

MilanKop • 18.4. 7:18

Makro smyčka

elninoslov • 18.4. 0:18

Makro smyčka

MilanKop • 17.4. 21:33