Příspěvky uživatele


< návrat zpět

Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 63

Funkce COUNTIF umí pracovat pouze s jednou podmínkou, pokud chcete zadat více podmínek, tak to lze přes podobnou funkci = COUNTIFS.

P.

Automaticky asi jedině přes maticový vzorec.

Případně by šlo udělat i přes kontingenční tabulku / filtr a automaticky aktualizovat makrem přes událost listu.

P.

Řešením je funkce SVYHLEDAT, případně ještě v kombinace s funkcí IFERROR.

Případně lze jako alternativu využít funkci INDEX v kombinaci s funkcí POZVYHLEDAT, a opět pro ošetření chybějících hodnot obalit do funkce IFERROR.

P.

Zkuste využít vyhledávací funkce - buď přímo SVYHLEDAT, případně nějaké kombinace INDEX a POZVYHLEDAT.
P.

Samotným vzorcem určitě hodnota trvale uchovat nepůjde. Jedině na daný problém vytvořit makro vázané na událost listu.

Doporučil bych si ale nejdříve nastudovat již vestavěné sledování změn, které Excel umožňuje (karta Revize / Sledování změn).

P.

Nejdříve bych si na tvém místě zjistil, co má vůbec funkce VYHLEDAT dělat.

Dle popisu funkce VYHLEDAT: Výsledek (ve tvém případě tam máš jen výraz "ANO") má být oblast obsahující pouze jeden řádek nebo sloupec + velikost oblasti je stejná jako velikost oblasti argumentu "Hledat" (ve tvém případě oblast $F$3:$F$134). Toto tedy tvůj zápis nesplňuje.

Navíc je tato funkce udělaná tak, že pokud nenajde přesnou shodu argumentu v dané oblasti, tak vrátí největší z menších hodnot. Jinými slovy pro řešení tvého problému to není úplně vhodná funkce. I když taky by to s ní teoreticky přes podmínku ve funkci KDYŽ šlo.
=IFERROR(KDYŽ(C3=VYHLEDAT(C3;$F$3:$F$359); "ANO"; ""); "")Nicméně funkce VYHLEDAT je již zastaralá a je v nabídce jenom z důvodu zpětné kompatibility předchozích verzí Excelu. Když už bys to chtěl řešit přes vyhledávací funkci, tak použij radši třeba SVYHLEDAT v kombinaci s funkcí JE.NEDEF.
=KDYŽ(JE.NEDEF(SVYHLEDAT(C3; $F$3:$F$359; 1; NEPRAVDA)); ""; "ANO")Já osobně bych to řešil přes funkci KDYŽ a COUNTIFS.=KDYŽ(COUNTIFS($F$3:$F$359; C3)>0; "ANO"; "")P.

Možným řešením je podmínka pro funkci KDYŽ složená z funkcí JE.NEDEF a SVYHLEDAT, případně podmínka funkce KDYŽ s COUNTIFS.
P.

Problémem je to, co tam píše i Excel = "Číslo uložené jako text".

Pro tyto případy lze použít ve vzorcích funkci HODNOTA, případně ve VBA si pohrát s funkcí VAL. Případně prostě a jednoduše jenom ty buňky vynásobit jedničkou (ať už ve VBA nebo ve vzorcích)...

P.

Vyřeší ti to funkce IFERROR.
P.

Trochu tě posunu, viz příloha a řádek 7 s kritériem, zda je daný test pro danou profesi požadován.
P.

Možná část postupu:

Jedno z možných řešení je použití "Plánovače úloh" ve Windows k pravidelnému otevírání excelového sešitu, kde pak bude nastavena událost sešitu "Workbook_Open".
P.

Příkaz "Range" v kombinaci s "Cells" se používá pouze pro definici oblasti.

Jinými slovy, když Range(Cells(1, 1)) zkrátíš na Cells(1, 1) tak by to mělo frčet.

P.

V podmíněném formátování toto asi nezměníš. Dalo by se to obejít třeba tak, že si tu podobnou šipku vložíš jako symbol do vedlejšího sloupce a přes podmíněné formátování jí nastavíš barvu.
P.

Stačí si pohrát s kombinací funkcí DOSADIT, ČÁST, NAJÍT a DÉLKA.
P.

=DOSADIT(ČÁST(A1; NAJÍT("-"; A1; 1)+2; DÉLKA(A1) - NAJÍT("-"; A1; 1)+2); " -"; ",")

Vznikla tady zřejmě určitá komunikační bariéra ;-).

1.) Když chcete, aby se počítal počet pracovních dní mezi dvěma daty přes funkci NETWORKDAYS bez svátků, tak musíte zadat poslední (nepovinný parametr), který se bude odkazovat na vypsané svátky daného roku.

2.) Pokud nezadáte onen parametr s výpisem svátků, tak se bude počet pracovních dní počítat i se svátky (každá země má svátky jindy a proto se musí Excelu přesně říci, které dny chcete jako svátek vykazovat).
P.


Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 63

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Porovnávací Tabulka

lubo • 25.6. 10:09

Porovnávací Tabulka

Jirka78 • 25.6. 9:21

Porovnávací Tabulka

Jess • 25.6. 6:46

rozlisna tlac excelu na 2 pc

elninoslov • 24.6. 23:28

Porovnávací Tabulka

elninoslov • 24.6. 23:26

Porovnávací Tabulka

Jess • 24.6. 22:46

rozlisna tlac excelu na 2 pc

Michalko • 24.6. 7:04