Příspěvky uživatele


< návrat zpět

Strana:  1 2 3 4 5 6 7 8 9   další » ... 15

Ahoj a děkuji.
Splňuje očekávání na jedničku.
Mazání řádků které jsem dále pro import nepotřeboval, bylo to nejsložitější.
Hlavně pokud jsem to dělal ručně tak jsem občas smazal i řádek který jsem neměl a hlavně bylo to časově náročné.

Děkuji moc.
R.

Bohužel zdrojové PDF ovlivnit schopen nejsem.
Ve většině případů zdrojových dat ale toto sloučení na řádku s adresou nebývá.

Jestli tedy mohu požádat neberte nyní tento řádek v potaz.
Děkuji

Dobrý den.

Mohl by mi někdo pomoci s kódem, který by odstranil všechny řádky, které nemají ve sloupci A číslo?
Odstranit všechny řádky, které mají původ záhlaví či zápatí, prázdné řádky. V příloze jsem vyznačil barevně co je potřeba odstraňovat.

Počet řádků je vždy jiný.

Slučuji několik PDF a následně je převádím na excel.
Používám následně importem do SW který mi optimalizuje trasu rozvozu.
SW pro optimalizaci trasy nepracuje s PDF.

Do připravené tabulky musím ještě přidat čísla PSČ a CZE do každého řádku, ale to už zvládám.

Děkuji moc

Děkuji oběma.

Na otázku co má být výsledkem je odpověď následující.
Pokud je den založení čtvrtek nebo pátek, tak musí od hodnoty ve sloupci J odečíst 48 hodiny.

Pokud je den založení sobota nebo neděle, musí od hodnoty ve sloupci J odečíst 24 hodin.

Potřebuji sledovat splnění reakční doby, která je stanovená na 2 dny od založení. Nepotřebuji to úplně přesně na hodiny , postačí mi dny.

Snad je to pochopitelné.

Děkuji
Radek

Ahoj.

Prosí o pomoc, jak spojit tyto čtyři podmínky.
Nepotřebuji makro, vystačím si se vzorcem.

1)=KDYŽ(I2=(DENTÝDNE(4;1));(J2-48);(J2))
2)=KDYŽ(I2=(DENTÝDNE(5;1));(J2-48);(J2))
3)=KDYŽ(I2=(DENTÝDNE(6;1));(J2-24);(J2))
4)=KDYŽ(I2=(DENTÝDNE(7;1));(J2-24);(J2))

Zkouším toto, ale nějak mi to nejde.
=KDYŽ(I2=(DENTÝDNE(4;1));(J2-48);(J2))=KDYŽ(I2=(DENTÝDNE(5;1));(J2-48);(J2))=KDYŽ(I2=(DENTÝDNE(6;1));(J2-24);(J2))=KDYŽ(I2=(DENTÝDNE(7;1));(J2-24);(J2))
vrátí se mi nepravda ať mám ve sloupci I jakýkoli datum.

Děkuji moc

Děkuji moc.

Elninislov děkuji za reakci.
Office ze kterých je odesíláno je 2013 a 2016.
Co se krokování týká, krokoval jsem od If Rcount >= 2 Then, ale stejně jsem na nic nepřišel.

Napadá Vás prosím třeba jiný způsob jak rozesílat odkazy jednotlivě na konkrétní osoby tak, aby se ostatní nemuseli zaobírat řádky, které pro ně nejsou určeny?

Děkuji moc.

Lugr, děkuji za snahu, ale článek na který mě odkazujete, nic neřeší.
Kopíruji pokaždé jiný hypertextový odkaz a pokaždé mám jiného adresáta do emailu.

Potřeboval bych jen vědět jak kopírovat a jak vložit hypertextový odkaz, aby nezměnil adresu ze serverové na lokál.

I tak děkuji

Dobrý večer. To se vážně nenajde někdo kdo by mi mohl pomoci?
Děkuji

Dobrý den.

Před odesláním emailu odkazuje hypertextový odkaz na síťové uložiště.
Po odeslání emailem se hypertextový odkaz odkazuje na lokální úložiště a ukáže se hláška, že odkaz nelze otevřít.

Náhled:
https://ibb.co/p3BQ7df
Vlevo zobrazuje obrázek odkaz na síťové uložení
Vpravo zobrazuje obrázek odkaz na lokální uložení po provedené proceduře.

Už nevím jak to lépe popsat.

Pro kopírování a vkládání používám:
rng.SpecialCells(xlCellTypeVisible).Copy
With NewWB.Sheets(1)
.Cells(1).PasteSpecial Paste:=8
.Cells(1).PasteSpecial xlPasteAll
Application.CutCopyMode = False
End With

ale ani toto nepomáhá.

Celá procedura v příloze.

Používám jako rozdělovník akcí.

Mohl by se prosím na to někdo podívat?
Děkuji

Tak jsem vyřešil tímto způsobem.

Sub celkovy_cas()

Dim radek As Integer
Dim posledni As Long
posledni = Workbooks("Nabídky vyhodnocení").Sheets("Data").Range("A1").CurrentRegion.Rows.Count

Range("ER2").FormulaR1C1 = _
"=SUMIF('Data ke strojům'!C[-145],Data!RC[-146],'Data ke strojům'!C[-135])"
Range("ER2").Copy
Workbooks("Nabídky vyhodnocení").Sheets("Data").Range("ER2", Sheets("Data").Range("ER" & posledni)).PasteSpecial
Workbooks("Nabídky vyhodnocení").Sheets("Data").Range("ER2", Sheets("Data").Range("ER" & posledni)).Copy
Range("ER2").PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
:=False, Transpose:=False
Application.CutCopyMode = False

End Sub

Děkuji za snahu.
Netušil jsem že, že když požádám o pomoc s proceduru na Svyhledat a sumif, že budeme debatovat na tím zda to potřebuji v proceduře či.
Jak jsem psal, mám důvody, proč to potřebuji ve VBA.
Pokud bych to chtěl v kontingenční tabulce, tak s tím tady neobtěžuji.

Asi to budu muset vyřešit jinde.
To je snad poprvé, co jsem zde nepochodil

Každopádně děkuji alespoň za nějakou reakci.

Děkuji za reakci.

64811 je jak ve VZORU (sl. A řádek 2) tak i v DATA KE STROJI(sl. A řádky 2a3) a tak i v DATA (sl. A řádek 2).

64882 je jak ve VZORU (sl. A řádek 3) tak i v DATA KE STROJI(sl. A řádky 15,16 a 17) a tak i v DATA (sl. A řádek 11).

Dá se tedy podle toho dohledávat.

Jinak potřebuji to do procedur, protože je to jen jeden úkon z mnoha.

Slouží to ke sčítání všech výrobních časů, režií, odpadu atd.. za jednotlivé stroje

Děkuji moc.

Pro lepší představu v listě Data ve sloupci ER by měl být takový vzorec
=SUMIF('Data ke strojům'!C:C;Data!B2;'Data ke strojům'!M:M)

A tak samo i ve sloupcích El až EQ.
Jen nevím jak to napasovat do VBA

Děkuji.

Ahoj.
Potřeboval bych pomoc s již částečně hotovou procedurou.
Do listu „Data“ podle hodnoty ve sloupci „B“ dostat do listu „Data ke strojům“ součet hodnot za jednotlivé sloupce G až M a tyty součty dostat do listu „Data“ sloupců EL až ER. Sloupce A až D z listu „Data ke strojům“ nakopírovat do listu „Data“ do sloupců sloupce „EF až EI“. bez součtu.

Na listě „VZOR“ je jak by mělo vypadat třeba u nabídek 64811 a 64882

Děkuji za případnou pomoc.

Aktuálně využívám toto, ale neprovádí mi tou součet času celkem.

Dim RadkuN As Long
Dim RadkuD As Long
Dim i As Long, aFind

Sheets("Data ke strojům").Range("A1:M1").Copy
Sheets("Data").Range("EF1").PasteSpecial
Application.CutCopyMode = False

RadkuD = Worksheets("Data").Cells(Rows.Count, 1).End(xlUp).Row
If RadkuD = 1 Then MsgBox "Žádné data.", vbExclamation: Exit Sub

With Worksheets("Data ke strojům")
RadkuN = .Cells(Rows.Count, 1).End(xlUp).Row
If RadkuN = 1 Then MsgBox "Žádné data.", vbExclamation: Exit Sub
aFind = Evaluate("=IFNA(MATCH('Data'!A2:A" & RadkuD & ",'Data ke strojům'!A2:A" & RadkuN & ",0),0)")

If IsArray(aFind) Then
For i = 1 To RadkuD - 1
If aFind(i, 1) > 0 Then .Range("A1:M1").Offset(aFind(i, 1), 0).Copy Worksheets("Data").Cells(i + 1, "EF")
Next i
Else

If aFind > 0 Then .Range("A2:M2").Copy Worksheets("Data").Cells(1, "EF")
End If
End With


Strana:  1 2 3 4 5 6 7 8 9   další » ... 15

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Výpočet odpracovaných hodin za den

elninoslov • 30.1. 0:35

Výpočet odpracovaných hodin za den

Mikus • 29.1. 21:58

vložit do bunky datum

PavDD • 29.1. 19:47

odkaz na zadanu cestu vba

jano5 • 29.1. 19:41

odkaz na zadanu cestu vba

jano5 • 29.1. 19:29

odkaz na zadanu cestu vba

elninoslov • 29.1. 17:33

odkaz na zadanu cestu vba

Lugr • 29.1. 17:19