Příspěvky uživatele


< návrat zpět

Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 69

Proč bys měl vyhledávat sazbu DPH? Prostě ji jen vepíšeš do tabulky a pak jen SUMIF.

Ahoj, zkus tohle:

Vyzkoušej:
Pravé tl. myši na soubor -> Vlastnosti -> karta Obecné a dole zatrhnout Odblokovat.

Range("D1").FormulaLocal = "=DOSADIT(ZLEVA(A" & j & ";HLEDAT("" "";A" & j & ")+2);"" "";"""")&"" Test_Q"" "

Edit:
nebo lépe
Range("D1").Formula = "=SUBSTITUTE(LEFT(A" & j & ",SEARCH("" "",A" & j & ")+2),"" "","""")&"" Test_Q"" "

Na tohle je super záznamník maker.
Takto vypadá vzorec pro výsledek ve sloupci B a hodnotu čerpanou ze sloupce A

ActiveCell.FormulaR1C1 = "=SUBSTITUTE(LEFT(RC[-1],SEARCH("" "",RC[-1])+2),"" "","""")&"" Test_Q"""

=DOSADIT(ZLEVA(A1;HLEDAT(" ";A1)+2);" ";"")

=DOSADIT(ZLEVA(A1;HLEDAT(" ";A1)+2);" ";"")&" Test_Q"

Do české varianty vzorce se mu vloudila anglická funkce LEN, přepiš na DÉLKA.

ide tam o nieco matematicke, co sme sa ucili na zakladnej skole - trojčlenka.

Třeba

Maticový vzorec, jeho zadání se ukončí CTRL+SHIFT+ENTER

???
With wsData
MaxR = .Cells(Rows.Count, 1).End(xlUp).Row + 1
With .Cells(MaxR, 1).Resize(R, S)
.NumberFormat = "General"
.Formula = "=REPT(" & Vzorec & "A2,1)"
.NumberFormat = "@"
.Value2 = .Value2
End With
End With

Snažíš se dělat průměr z TEXTU nikoliv čísla.
Označen sloupec E -> CTRL+H -> najit "tečku", nahradit "čárku"

rozlišuje malá a velká písmena v textu, což už je větší problém

Funkci NAJÍT vyměň za HLEDAT a máš po problému.

Jednoduše:
=KDYŽ(E13>=1;KDYŽ(F13>400;1,5*F13;600);"")

Další studijní materiál:
https://www.encodedna.com/excel/how-to-add-events-to-dynamically-created-controls-in-excel-using-vba.htm


Strana:  « předchozí  1 2 3 4 5 6 7 8 9   další » ... 69

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46

vrácené hodnoty

Anonym • 22.5. 15:45