Příspěvky uživatele


< návrat zpět

Strana:  1 2 3 4 5 6 7 8 9   další » ... 44

Jakou chybu to vyhodí?
Jak pokračuje ten vzorec za DV - to tu není vidět.

Když vložíte soubor s makrem, líp se bude hledat chyba.

do buňky J3: =KDYŽ(C3>0;KDYŽ(SUMA(F3:H3)>C3;0;C3-SUMA(F3:H3));C3)
do buňky K3: =SUMA(C3:D3)-SUMA(F3:H3)-J3

a roztáhnout na další řádky.

Do buňky A2 napsat 20230001
Do buňky A13 napsat 20230002
označit buňky A2:A24
výběr chytnout za pravý dolní roh a přetáhnout dolů, kam až potřebuji.
A25, A36 atd. se pak vyplní postupně řadou.

Nevím, jestli je to záměr, ale mezi A2:A13 je 11 buněk
a A13:A24 je 12 buněk.Stejný rozdíl se bude aplikovat i dál. Nejdřív 11, 12, 11, 12 atd...

@lubo také děkuji.

Já bych asi testoval buňku po buňce, jestli už patří do Tabulky nebo ne.
"Intersect" mě vůbec nenapadl. A přitom tak jednoduché a rychlé řešení.

A ano, máte pravdu. Kvůli jednomu řádku hromada testů.

Děkuji za příklad řešení.
Kontrola listu nebude nutná, protože makro se bude spouštět z toho listu a bez dané Tabulky nemá smysl makro spouštět.
Ale určitě kvůli komplexnosti to je dobré doplnit.

Prosím o pomoc
Mám excelovou Tabulku, která se jmenuje "Tabulka".
Umím vybrat konkrétní buňku v Tabulce.
ListObjects("Tabulka").DataBodyRange(3, 2).Select
ListObjects("Tabulka").ListColumns(2).Range(2).Select
ListObjects("Tablka").ListRows(4).Range(1).Select

Nevím však, jak zjistit, který řádek tabulky je vybraný.
Něco jako ActiveCell.Row, ale pro Tabulku.
Když znám na kterém řádku tabulka leží, tak si to odečtu, ale co když to nevím?
Napadá mě jedině testovat řádek po řádku, jestli leží v dané Tabulce a pak si to dopočítat.

Nemáte někdo zkušenosti?
Dík.

Místo "název souboru" např. "filename"?

V české verzi je to takto:
=ZLEVA(POLÍČKO("názevsouboru";A1);NAJÍT("[";POLÍČKO("názevsouboru";A1);1)-1)

Jak říká @elnino. V CZ Excel Formula1:="=DENTÝDNE(I$1;2)>5").Interior

Třebs tskto?

Jedna z možností:=IFERROR(KDYŽ(ZLEVA(A2;2)="04";SVYHLEDAT(ZLEVA(A2;2)&"????";dopln!$A$2:$B$4;2;NEPRAVDA);SVYHLEDAT(ZLEVA(A2;3)&"????";dopln!$A$2:$B$4;2;NEPRAVDA));"")

Tak tady je to i s vyhledáním záhlaví (ciste, 1a, 1b..).
Samozřejmě, že v listech 1 - 3 musí být struktura tabulky stejná.

=SOUČIN.SKALÁRNÍ(SUMIF(NEPŘÍMÝ.ODKAZ("'"&NEPŘÍMÝ.ODKAZ("$X$2:$X$"&POČET($X:$X)+1)&"'!$C$2:$C$19");D$1;NEPŘÍMÝ.ODKAZ("'"&NEPŘÍMÝ.ODKAZ("$X$2:$X$"&POČET($X:$X)+1)&"'!"&ODKAZ(2;POZVYHLEDAT($A2;'1'!$1:$1;0))&":"&ODKAZ(19;POZVYHLEDAT($A2;'1'!$1:$1;0)))))

Možná bych to zjednodušil.
Předpokládám, že sloupce ciste, 1a, 1b, 1c a 1d budou v listech 1 - 3 stále na stejném místě. Proto bych v listu Seria natvrdo zadal tyto sloupce. Vzorec bude potom jednodušší.

=SOUČIN.SKALÁRNÍ(SUMIF(NEPŘÍMÝ.ODKAZ("'"&NEPŘÍMÝ.ODKAZ("$X$2:$X$"&POČET($X:$X)+1)&"'!$C$2:$C$19");D$1;NEPŘÍMÝ.ODKAZ("'"&NEPŘÍMÝ.ODKAZ("$X$2:$X$"&POČET($X:$X)+1)&"'!$D$2:$D$19")))

Jen jsem na to v rychlosti mrknul a přiznávám, že z toho nejsem moc moudrý. Možná to ostatní pochopili.
Já bych potřeboval, abyste ručně vyplnil více buněk v tabulce, abych si to mohl nějak odvodit, co vlastně chcete.

Třeba takto


Strana:  1 2 3 4 5 6 7 8 9   další » ... 44

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

náhled web stránek v Excelu

elninoslov • 23.2. 17:38

náhled web stránek v Excelu

elninoslov • 23.2. 11:17

náhled web stránek v Excelu

zdena • 23.2. 10:01

Timeplan

CMM-Team • 23.2. 9:21

Nechci při importu odebírat prázdné řádky

elninoslov • 23.2. 9:19

náhled web stránek v Excelu

elninoslov • 23.2. 9:13

náhled web stránek v Excelu

zdena • 22.2. 17:08