Příspěvky uživatele


< návrat zpět

Strana:  1 2 3 4 5 6 7 8 9   další » ... 29

nevím další použití ale mohlo by pomoci
eng DATEVALUE
cz DATUMHODN
které převede text na pořadové číslo

Najít -> Nahradit ?

Ctrl+f

do původních dat jsem na řádku 5 přidal datum s rokem 2025 a další dva sloupce,
Zkuste si přidat další sloupec případně datum a aktualizovat dotaz Výstup který vytváří tabulku na listu Výstup
teď by mělo být jedno kolik sloupců bude ve zdroji, všechny se objeví ve výstupu

Takto?
Nechal jsem jen vytvořený dotaz nenačtený do listu excelu.

já to zapomněl poupravit v COUNTIF 5
a chybu jsem doufal že už si ošetří autor

zkuste maticově
=INDEX($H$1:$H$456;POZVYHLEDAT(0;COUNTIF($H$1:H1;$H$1:$H$456);0))
a potáhnout až kam je potřeba

edit: také by šlo použít Power Query

použijte fci KDYŽ
když výsledek menší než X tak 0,9krát X
když větší 1,1 krát X

Tabulka1 je tabulka zdrojových dat na listu evidence, tu jste si musel vytvořit sám. Excel jí jen pojmenoval.
Pokud Tabulku1 přejmenujete (třeba ve správci názvů), nebude vám dotaz fungovat takže pozor. (to jen na okraj ;-))
Ve zdrojových datech si můžete dělat co se vám zlíbí a v rámci toho co vám Excel dovolí. S PQ to nesouvisí. Na co si dát pozor je například přejmenování sloupců ve zdrojových datech což si ostatně můžete sám vyzkoušet pokud chcete. ;)
přidejte si např. na listu Evidence ve sloupci název druhu mezeru do názvu a váš dotaz už nebude fungovat.

tak nějak uplně přesně nevím co pod některými pojmy myslíte takže zkusím jen od boku.
Každý dotaz potřebuje "Zdroj dat" ve vašem případě
= Excel.CurrentWorkbook(){[Name="Tabulka1"]}[Content]
tzn. že dotaz načítá data z Tabulka1 v aktuálním sešitě.
Data se dají načítat mnoha různými způsoby, z Tabulky jiného sešitu, z txt, xml souborů, přímo z webu atd.

Potřebuji v průběhu postupného vyplňování záznamů v zájmu chronologického a i jiného řazení a seskupování některé řádky (ručně) přesouvat.

Kde? Ve zdrojových datech?
ten dotaz tak nějak tu výchozí tabulku svazuje a omezuje a nedovolí manipulaci s řádky,

co myslíte manipulací s řádky?

v dotazu máte seskupené řádky a tam si přidejte seskupení na sloupce které chcete přidat

příloha není asi se nepovedlo nebo to zkuste zabalit do archivu

Ahoj
VBA neumím, tak jsem zkusil použít Power Query. Na listu XML_vstup jsou načtená data z výše zmíněného odkazu.
na listu Výstup jsou data upravena a přeuspořádána a je použit Průřez plus jsem eliminoval data kde celní expirace je staršího data než Dnes (aktuální datum při otevření souboru)
Můžete zkusit jestli by vám to vyhovovalo, případně by šli udělat úpravy.

edit: nechce mi to nahrát soubor, zkusím později

dal jsem to na edisk https://www.edisk.cz/stahni/97198/celni-sazebnik-testpq-3.69-mb.html/

eltazar napsal/a:


díky, ale použití čísla sloupce se chci právě vyhnout, a místo toho odkázat na název sloupce. Viz. první příklad, =SVYHLEDAT(P136;objednavky;2;NEPRAVDA) = funguje, vyhledá 2 sloupec v tabulce objednávky

ach jo se mnou :-)

jak psal elnino
=SVYHLEDAT(A1;objednávky[#Vše];SLOUPEC(objednávky[[#Záhlaví];[zákazník]]);NEPRAVDA)

nevím jestli to bude fungovat v 2010 ale zkuste

=SVYHLEDAT(P136;objednavky[#Vše];"číslo sloupce";NEPRAVDA)

šlo by to i pomocí PoweQuery, musel jsem hodně pátrat abych něco dohledal na práci s textem, udělat malé úpravy zdrojových dat ale nakonec se snad povedlo
Zkuste mrknout


Strana:  1 2 3 4 5 6 7 8 9   další » ... 29

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Tlac s farebneho

ivana1 • 19.6. 22:16

GRAF teploty

Scraper • 18.6. 15:34

Vyhledat dnešní datum když je číslo jako text

veny • 17.6. 13:56

Vyhledat dnešní datum když je číslo jako text

Ontik • 17.6. 12:07

Zaokrouhlování

lubo • 17.6. 12:03

Zaokrouhlování

JoKe • 14.6. 15:19

Zaokrouhlování

Mirek-Kraus • 14.6. 13:52