Příspěvky uživatele


< návrat zpět

Strana:  1 2 3 4 5 6 7 8 9   další » ... 20

Dobrý den
Pokud by to nevadilo (nevím jakou verzi Excelu používáte), šlo by to pomocí Power Query.
Důležité:
Pokud budete mít otevřený i jiný sešit Ecelu, je potřeba na Listu Nastavení v buňce B1 zadat natvrdo cestu k souboru i s názvem souboru včetně koncovky.
Dále jsem přidělal Tabulku s výpisem Listů, oblast kde zadáte které listy chcete propočítat a Tabulku věcí které budete vydávat s jednotkovou cenou.
Na listu Výstup je potom souhrnná Tabulka vydaných věcí a propočet.
Při změnách, je potřeba soubor uložit a Tabulky aktualizovat na kartě Data-Aktualizovat vše, nebo po uložení souboru pravým klikem na tabulku a Obnovit.

Pokud by bylo potřeba nějaké úpravy, opravy, nebo vysvětlení klidně pište.

Janinka88 napsal/a:

Pro příklad: Jde o to že se někdy řádky přidávají a zase odstraňují a tak se funkce
=SUMA(A4:A10000)
kterou mám ve A3 se mění na ....A9999 nebo zase .....A10001 a protože mám i nějaká data v A1 a A2 tak nejde použít


a nestačilo by zamknout buňky ve vzorci?
=SUMA($A$4:$A$10000)

pomocí PowerQuery třeba takto

musel jsem to zabalit kvůli velikosti

MarMit napsal/a:

Veny, práve tak som to mal aj vypracované, úplne jednoducho a vedúcemu sa to nepáčilo Potreboval som to približne tak, ako to Pavelo navrhol
Veľmi pekne Vám ešte raz ďakujem.

Mně děkovat nemusíte, protože opravdu není za co.
To, že jste to nějak měl a chcete to jinak jsme nevěděli. 2

vložte přílohu se smyšlenými daty ale stejnou strukturou
pro vkládání přílohy je potřeba se zaregistrovat.

zjednodušeně
sečtěte starou a novou a od toho odečtěte plánovanou

do buňky B1 si dejte vzorec
=ČÁST($A1;SLOUPCE($A$1:A$1);1)
a potáhněte doprava a případně dolů,
jen dát pozor na velikost oblasti podle nejdelšího slova(čísla)

myslíte to takto?
PF je dělaný jen pro buňku AC19

edit:
koukal jsem že tam mám špatně zámky, zamčený má být řádek a ne sloupec, kvůli rozkopírování

rádo se stalo

pokud nevadí rozdělení rozmezí na dva sloupce, tak třeba takto

pro buňku "I1"
="Celkový zisk v CZK: " & HODNOTA.NA.TEXT(SUBTOTAL(9;F2:F1000);"### ### ##0,00")

nejsem přes VBA takže jen pomocí záznamníku plus doplnění sellect
určitě to půjde mnohem lépe a hezčeji 3
Sub Nbr()
Range("A1").Select
ActiveCell.FormulaR1C1 = "10"
Range("A2").Select
ActiveCell.FormulaR1C1 = "20"
Range("A1:A2").Select
Selection.AutoFill Destination:=Range("A1:A10"), Type:=xlFillDefault
Range("A1:A10").Select
End Sub

A z toho odkazu co jsem dal to nemůžete použít? Jinak stačí použít třeba Google.
Myslím že nemá cenu aby někdo něco vymýšlel co už je vymyšlené. Pokud máte nějakou speciální představu tak dejte přílohu.

Vyhledejte si Bergerovy tabulky, určitě najdete něco ke stažení eventuálně si je upravíte k obrazu svému.

Edit: třeba i tady na wall https://wall.cz/index.php?m=topic&id=35592&page=2#posts

A máte tam maticový vzorec rozkopírovaný dolů? protože u mě to funguje

musíte mít zamčené buňky ve vzorci v pomocných sloupcích tak jak to má Jiří497
=IFERROR(INDEX($D$2:$D$90;SMALL(KDYŽ(($A$2:$A$90=TABULKA!$B$4)*($B$2:$B$90=TABULKA!$B$5)*($C$2:$C$90=TABULKA!$B$6)*(COUNTIF(J$1:J1;$D$2:$D$90)=0);ŘÁDEK($D$2:$D$90)-1);1));"")


Strana:  1 2 3 4 5 6 7 8 9   další » ... 20

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Kumulace listů do jednoho listu

Lugr • 28.9. 11:24

Kumulace listů do jednoho listu

veny • 27.9. 11:23

skenovani a vyhledavani a oznaceni v tabulce

elninoslov • 24.9. 23:11

Kumulace listů do jednoho listu

MonikaV • 24.9. 17:18

skenovani a vyhledavani a oznaceni v tabulce

djph • 24.9. 13:44

Sečíst sloupec od 4 řádku

madar5 • 23.9. 8:32

Ověření dat

lubo • 22.9. 11:25