< návrat zpět

MS Excel


Téma: Dynamická oblast buňek rss

Zaslal/a 17.1.2010 18:49

Dobrý den

Mám dotaz ohledně dynamické oblasti dat ve vzorci. Pro jednoduchost, mám vzorec který mi sečte všechny buňky ve sloupci D "=suma(D:D)". Lze nějak definovat tu oblast (D:D)? Tzn že budu chtít sečíst položky ve sloupci pojmenovaném například "CELKEM", jenže nevím, který sloupec to konkrétně bude (D,E,F....). Nemusí to sloupec najít úplně samo (i když by to bylo nejlepší), stačilo by třeba čerpat z buňky A1, do které bych ručně zadal písmeno sloupce, který chci sečíst (v našem případě bych do buňky zadal písmeno "D"). Předem díky

Zaslat odpověď >

icon #001067
Poki
Zdravím,

1) pokud jde o možnost, která spočítá sumu sloupce zapsaném v bunce A1 - stačí do bunky, ve které má být součet napsat tento vzorec: =SUMA(NEPŘÍMÝ.ODKAZ((A1&":"&A1)))

2) pokud by měl být vybrán sloupec automaticky, muselo by se vedet, jak lze tento sloupec urcit - nejaka podminka nebo tak neco. Jestli to chápu dobře, tak by v první bunce sloupce byl nápis "Celkem", potom by vzorec vypadal takto:
=SUMA(POSUN(A1;0;POZVYHLEDAT("Celkem";1:1;0)-1;65500;1))citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

rozpis zápasů hráčů pro utkání dvou týmů

Anonym • 25.5. 11:54

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46