< návrat zpět

MS Excel


Téma: maticový průměr buněk s podmínkami rss

Zaslal/a 18.12.2012 9:59

Ahoj, už delší dobu si lámu hlavu s výpočtem průměru buněk v maticovém vzorci.

Sloupec B jsou měsíce
Sloupec C jsou číselné hodnoty
Buňka F2 obsahuje název měsíce (nebo "vše")
Buňka F3 obsahuje vzorec


Pro SUMU buněk mám maticový vzorec, který bez problémů funguje:
=SUMA(
(KDYŽ(F2="Vše";1;B2:B11=F2))*
(C2:C11)
)

To samé (za stávající podmínky když) bych potřeboval pro průměr buněk C2:C11

Prosím, nevíte někdo, jak na to? Děkuji.

Zaslat odpověď >

#010691
avatar
jen od pasu: co takhle zmenit SUMu za SUBTOTAL s argumentem 1?citovat
#010694
avatar
=SUBTOTAL(1;
(KDYŽ(F2="Vše";1;B2:B11=F2))*
(C2:C11)
)

"Napsaný vzorec obsahuje chybu"...citovat
#010697
Stalker
Excel 2007 a výš
AVERAGEIF
AVERAGEIFScitovat
icon #010701
avatar
Pokiaľ to riešiš maticovým vzorcom tak suma sa dá napísať i bez KDYŽ ako:

=SUMA((B2:B11=F2)*C2:C11)

priemer potom v tvare

=SUMA((B2:B11=F2)*C2:C11)/SUMA(--(B2:B11=F2))citovat
#010704
Stalker
@AL
"Pokiaľ to riešiš maticovým vzorcom tak suma sa dá napísať i bez KDYŽ"
To máš sice pravdu, ale potom nemůže použít kritérium "Vše"
viz: Buňka F2 obsahuje název měsíce (nebo "vše")

Ten průměr se dá řešit i bez maticového vzorce jako
sumif/countif

=SUMIF(B2:B11;F2;C2:C11)/COUNTIF(B2:B11;F2)citovat
icon #010705
avatar
@Stalker: JJ, som nepopozorný, máš pravdu, díky za opravu.citovat
#010730
avatar
Díky všem :)
Protože se mi to nechtělo řešit přes dělení (což by samotný vzorec prodloužilo o dvojnásobek), použil jsem nematicové AVERAGEIFS, protože se to i tak lépe hodí, jelikož mám více podmínek než jen volbu měsíce :)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

microsoft 365 hlaska sharepoint

jano1 • 20.7. 16:59

Názvy z řádků do sloupců Power Query

Alfan • 19.7. 13:49

Názvy z řádků do sloupců Power Query

lubo • 19.7. 12:24

vyhledání obsahu buňky

vfort • 18.7. 11:22

Názvy z řádků do sloupců Power Query

Alfan • 18.7. 10:01

Tlac 2 roznych tabuliek

loksik.lubos • 17.7. 20:43

Týden v roce

Petr92 • 16.7. 15:34