< návrat zpět

MS Excel


Téma: Docházka rss

Zaslal/a 11.2.2013 16:11

Dobrý den.
Prosím Vás o radu.Nevím si rady se vzorcem na počítání času tak aby odpočítal přestávku v práci a celkový počet hodin.Pro lepší představu posilám svoji vytvořenou aplikaci.Předem děkuji.

Zaslat odpověď >

#011593
avatar
přílohu nevidímcitovat
#011594
avatar
Nějak mi sem nejde nakopírovatcitovat
#011596
M+
asi je třeba se zaregistrovat, pak by to mělo jít
http://wall.cz/index.php?m=topic&id=8351citovat
#011598
avatar
Tak jsi měl pravdu.
Příloha: zip11598_dochazka.zip (18kB, staženo 41x)
citovat
#011601
avatar
Pokud tomu rozumím, tak to je pouze jednoduchá matematika, ne? Vezmeš "konec směny" mínus "začátek směny" a od toho odečteš délku přestávky, tedy "konec přestávky" mínus "začátek přestávky".
P.

Př.:
=C11-C8-(C10-C9)citovat
#011602
avatar
Díky už to funguje.Ještě bych potřeboval poradit,aby při zadání D (dovolené)se zobrazilo ve skutečném odpr.směny hodnota 7:75.
Prosím tě a ten celkový počet hodin mám správně?
=SUMA(C12:AG12)citovat
#011603
avatar
Sumu tam máš definovanou správně.
U té dovolené lze využít např. funkci KDYŽ. Nevím přesně kam do "D" píšeš, pokud do začátku směny, tak třeba nějak takto. (ten čas asi myslíš 7:45)
P.

Př.:
=KDYŽ(C8="D";ČASHODN("7:45");C11-C8-(C10-C9))citovat
#042184
avatar
Já to řešil u brigádníků trošičku jinak na sloupci B datum, na C začátek směny, D konec sm., E přestávka, G odpracováno (kdy dole byla suma, tam jsem jen musel upravit sčítání nad 24 hodin 1 ). Přestávka se mi odečítala jen u směn delších 6 hodin. Vzorce byly u přestávky* =KDYŽ(((C6+D6)-(C6+C6))>$C$39;$D$39;0) **a u součtu za den** =((C6+D6)-(C6+C6)-E6) 1citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

microsoft 365 hlaska sharepoint

jano1 • 20.7. 16:59

Názvy z řádků do sloupců Power Query

Alfan • 19.7. 13:49

Názvy z řádků do sloupců Power Query

lubo • 19.7. 12:24

vyhledání obsahu buňky

vfort • 18.7. 11:22

Názvy z řádků do sloupců Power Query

Alfan • 18.7. 10:01

Tlac 2 roznych tabuliek

loksik.lubos • 17.7. 20:43

Týden v roce

Petr92 • 16.7. 15:34