< návrat zpět

MS Excel


Téma: součet skalár. součinů rss

Zaslal/a 20.2.2010 23:25

Zdravím, dá se nějak vykrátit vzorec (zjednodušen pro přehlednost)
SOUČIN.SKALÁRNÍ((A1:A5=H1)*(B1:B5=I1))+SOUČIN.SKALÁRNÍ((C1:C5=H1)*(D1:D5=I1))
tak, abych napsal SOUČIN.SKALÁRNÍ do vzorce jen 1x?

jinak řečeno, potřebuji součet skalárních součinů lichých sloupců. Je jich celkem devět, šlo by to samozřejmě řešit primitivním součtem, ale nechce se mi dělat deset řádků dlouhý vzorec, jistě to jde elegantněji, ale skalární součiny nejsou moje parketa.

Díky Honza V

Zaslat odpověď >

#001223
avatar
oprava, první polovina je stále stejná A1:A5, v druhých závorkách jsou pak sloupce B1:B5, D1:D5, E1:E5 atd. Díkycitovat
icon #001236
Poki
Zdravice,
tohle jsem teda vůbec nepochopil (a asi ani jini, kdyz nikdo neodpovedel), ale pokud potrebujes soucet skalarnich soucinu sloupce A s dalsimi, tedy A*B + A*C + A*D + A*E, pak lze pouzit tento maticovy vzorec (je treba ukoncit CTRL+SHIFT+ENTER)

=SUMA((A1:A5)*(B1:B5);(A1:A5)*(C1:C5);(A1:A5)*(D1:D5);(A1:A5)*(E1:E5))citovat
#001237
avatar
jo, to vypadá dobře, zkusím to a dám vědět.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

ADO DBF/FoxPro

Barth • 11.8. 17:50

Automaticke vlozenie riadku aj v druhom Zosite

danis • 11.8. 17:28

Macro pro leteckou dopravu

Jiří497 • 11.8. 17:15

Macro pro leteckou dopravu

Nosal • 11.8. 13:00

Macro pro leteckou dopravu

Jiří497 • 11.8. 11:45

Macro pro leteckou dopravu

Nosal • 11.8. 8:14

Macro pro leteckou dopravu

Jiří497 • 10.8. 21:35