< návrat zpět

MS Excel


Téma: Vyhledání a sečtení rss

Zaslal/a 21.2.2010 12:57

orinokoChci vás poprosit o pomoc. Mám záznam viz.příloha, kde v listu:odstávky z PSS potřebuji vyhledat podle sloupce (H33)linku a podle sloupce (E33)poruchu a výsledky v slopci (D33) sečíst.

Děkuji za pomoc

Příloha: rar1224_kopie-sledovani-prostoju-2010-w6.rar (70kB, staženo 31x)
Jméno
Kontrola
Text
  b i u s img code url hr   1 2 3 4 5 6 7 8 9 10

#001230
avatar
Ak tomu dobre rozumiem, tak by bola ideálna kontigenčná tabuľka.
Treba pomôcťcitovat
icon #001235
Poki
Nevim, jestli jsem to dobře pochopil, protože tech linek a typů poruch je tam moře a nevim, co přesně je požadovaný výstup.

Pokud chceš sečíst např. poruchu 'OK Start' u linky 'F16', lze použít tento matickový vzorec (musí se ukončit CTRL+SHIFT+ENTER)

=SUMA((H34:H1838="FIN16")*(E34:E1838="OK Start")*(D34:D1838))citovat
#001256
orinoko
Tu kontingenčnú tabulku som vyskúšal no po roztriedení musím ešte sčítat a preniest záznam do hornej tabulky. Data pre kontingenčnú tabulku sa natahuju z vedlajsieho listu.Problem je i v tom, že počet riadkov a názov daneho záznamu sa mení. Pre vyhladanie a scitanie som pouzil SUMIF. Myslim že by bolo na to idealne makro no to neviem ako sa programuje.
Příloha: rar1256_kopie-w6.rar (88kB, staženo 31x)
citovat
#001261
avatar
Ak je hľadaný problém výsledok v tabuľke "odstavky z PSS A:1;J:10, potom by mohol pomôcť vzorec SUMIFS

=SUMIFS('odstávky z PSS'!$E$7:$E$2000;'odstávky z PSS'!$I$7:$I$2000;"FIN9";'odstávky z PSS'!$F$7:$F$2000;A2)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse