< návrat zpět

MS Excel


Téma: SVYHLEDAT+KDYŽ-problém rss

Zaslal/a 2.3.2010 13:34

Dobrý den,
prosím o pomoc: vytvářím klakulační tabulku, kde zadám rozměr výrobku a typ výroby (offset nebo digitální tisk) a potřebuji, abych po zvolení rozměru výrobku a typu výroby (offset nebo digitální tisk) dostal cenu za kus, odpovídající zvolenému typu výroby.
Nemohli byste mě trochu usměrnit? Případně vysvětlit, jestli na to nejdu špatně?
Zástupný soubor přikládám.
Moc děkuji!

Příloha: rar1288_pokus_01.rar (7kB, staženo 30x)
stop Uzamčeno - nelze přidávat nové příspěvky.

icon #001289
Poki
Zdravím,
zkusil bych tenhle vzorec do bunky C2
=KDYŽ(NEBO(JE.PRÁZDNÉ(A2)=PRAVDA;JE.PRÁZDNÉ(B2)=PRAVDA);"";SVYHLEDAT(A2;data!A:C;KDYŽ(List1!B2="offset";2;KDYŽ(List1!B2="digitální tisk";3;0));NEPRAVDA))citovat
#001291
Jeza.m
Přikládám 2 příklady (jako prostřední jsem přihodil i Pokiho vzorec) :-)

ono způsobů je asi spousta, ale ten poslední je takový nejuniverzálnější, niméně vyžaduje aby hlavička v listu data byla shodná s výběrem ve sloupci B.

M@
Příloha: zip1291_pokus_01.zip (8kB, staženo 33x)
citovat
#001307
avatar
Děkuji mockrát,
vzhledem k tomu, že jsem v excelu totální trotl a na začátku, jsem se Vašim řešením pěkně zasmál, protože jsem tomu nerozuměl ani trochu...ale někde jsem četl, že nejlepší hra je excel, takže ty Vaše vzorce začnu pomaličku pitvat...a vlastně si budu hrát...
Ještě jednou díky!!! 4citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse