< návrat zpět

MS Excel


Téma: automatická poznámka a funkce když rss

Zaslal/a 18.4.2013 9:05

Zdravím,
potřebuji pomoci s objednávkovou tabulkou...
V 1. listu je obj. form., ve druhém seznam zákazníků, který se zkopíroval do buňky v 1. listu jako "seznam výběru" (zákazník se vybírá pomocí šipky).
Potřebuji, aby např. u dvou zákazníků, pokud si objednají jeden z nabízených produktů byla poznámka typu "jiný druh".
V buňce by tedy měly být min. dvě funkce
=když si zákazník A nebo B objedná položku č. 1, musí se objevit poznámka "jiný druh", pokud si objedná někdo jiný to samé zboží, pozn. by se zobrazovat neměla.
Díky za radu.

Příloha: zip12964_zkouska.zip (7kB, staženo 14x)
Zaslat odpověď >

#012965
avatar
A mohol by si priložiť aj vyplnený príklad? Akosi to celkom nechápem. Je tam iba jeden zákazník a žiadny druh. 7citovat
#012966
avatar
v druhém listu je seznam zákazníků, v prvním listu se vybere v poli pomocí šipky.
Žádný další vzorec tam zatím není.citovat
#012969
avatar
No v prvom liste máš vyplneného zákazníka PRAHA. A kde je vyplnený ten druhý zákazník a čo si objednal? S čím to mám porovnávať. Čo som veštec, aby som uhádol, čo tam bude vyplnené?citovat
#012970
avatar
když klikneš na pole B1 ukáže se ti šipka, můžeš si tak vybrat z vícero zákazníků (tento seznam je zkopírovaný z listu2).
Pokud si praha a nebo olomouc objedná např. 1 chleba (1 a více), musí se v poznámce objevit "jiný druh".
Měla by tam být podmínka typu "když si praha ANEBO olomouc objedná 1 a více ks chleba, musí se vedle v řádku C5 objevit, že chtějí "jiný druh".citovat
#012971
avatar
Keď kliknem na šípku a dám OLOMOUC, tak ako mám vedieť, že tam predtým bola PRAHA a že si objednala tiež CHLIEB? 4citovat
#012973
avatar
není třeba vědět, co si kdo objednal předtím.
Jde o zjednodušený objednávkový formulář. Víme, že Praha a olomouc si obvykle objednávají chléb, ale chtějí "jiný druh", než ostatní většina zákazníků. To by byla automatická poznámka pro nás, abychom mu nezapoměli vychystat jiný druh tohoto zboží (chleba).citovat
#012974
avatar
Do bunky C5 si daj
=IF(OR(B1="Praha";B1="Olomouc");"Jiný druh";"")

=KDYŽ(NEBO(B1="Praha";B1="Olomouc");"Jiný druh";"")citovat
#012975
avatar
díky za ochotu, potřebovala bych to ale ještě tak, aby se ten text "jiný druh", objevil jen když si skutečně to zboží (chleba) objednají.. vsunout do vzorce =když(B5>0;"jiný druh";"")citovat
#012977
avatar
=KDYŽ(NEBO(B1="Praha";B1="Olomouc");když(B5>0;"jiný druh";"");"")citovat
#012978
avatar
úžasné, super. Funguje :)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse