< návrat zpět

MS Excel


Téma: Výpočet provize na základě různých pásem rss

Zaslal/a 9.5.2013 16:26

Dobrý den,
potřeboval bych poradit od někoho zkušenějšího než já s následujícím oříškem:

Nemohu přijít na to, jak naučit Excel počítat provize z celkové částky, když chci, aby kalkuloval s určitým procentem za každé "pásmo", které celková částka splní (protne).

Příklad:

Provizní pásma jsou např.:

0-10000 Kč = 60%
10001-20000 Kč = 65%
20001-30000 Kč = 70% (atd.)

Karel vytvořil obrat 23500 Kč. Tzn, že mu náleží provize z:

10000 * 0,6 = 6000,00 Kč
9999 * 0,65 = 6499,35 Kč
3499 * 0,70 = 2449,30 Kč

Celkem = 14948,65 Kč

Nevím, jak přiměji Excel, aby rozdělil výpočet do těchto kroků a aby to zároveň bylo funkční i v případě, že Karel někdy udělá obrat nižší, než je cílová hranice prvního pásma (obrat ne vždy protne všechna nastavená pásma).

Budu vděčný za každou radu 1

Soubor přikládám, používám Excel 2007

Příloha: rar13248_vypocet_odmen.rar (8kB, staženo 66x)
stop Uzamčeno - nelze přidávat nové příspěvky.

#013253
Opičák
Řešení funkcí ??
Příloha: zip13253_provize.zip (16kB, staženo 69x)
citovat
#013254
Opičák
Je třeba stanovit maximální mez provize ! Funkce toto omezení nemá!
20001-30000 Kč = 70% (atd.)
právě v tom atd. je problém, po určitém přičítání 5 procent se dostanete nad 100 procent provize, což je nesmysl.citovat
#013255
Opičák
Tady je funkce upravená s možností (nutností) stanovit argumnty fce a to navýšení (po 10000), minimální procenta (60), maximální procenta (80) a skok (5 procent).
Příloha: zip13255_provize2.zip (18kB, staženo 52x)
citovat
icon #013256
eLCHa
Zapomeňte už jednou na makra, když je nepotřebujete

Pro tento konkrétní případ:
Do buňky D2 vložte vzorec
=B2*$H$2+((B2-$G$2)>0)*(B2-$G$2)*($H$3-$H$2)+((B2-$G$3)>0)*(B2-$G$3)*($H$4-$H$3)+((B2-$G$4)>0)*(B2-$G$4)*($H$5-$H$4)
a zkopírujte

Pokud budu mít chviličku, ještě se kouknu, mohlo by to jít i jednodušeji (obecněji)citovat
icon #013257
eLCHa
Takže ta chvilička se vyskytla poměrně brzo

=SOUČIN.SKALÁRNÍ(((B3-$G$2:$G$5)>0)/1;(B3-$G$2:$G$5);($H$3:$H$6-$H$2:$H$5))

Je tam třeba vložit skrytý řádek. Viz příloha
Příloha: zip13257_vypocet_odmen.zip (10kB, staženo 96x)
citovat
#013260
avatar
Geniální! Moc pomohlo a děkuji za pomoc 9citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse